Forums | Mahara Community

Mahara/Moodle integration /
Mahara created multiple users for one account that comes from Moodle


Margari León's profile picture
Posts: 8

16 November 2017, 10:50 PM

Hello:

We have connected Moodle and Mahara, but when a user from Moodle goes to Mahara, it creates a new user for him each time that opens a session...

We have Moodle v. 3.3.2 and Mahara v. 17.04.2

Can someone help me?

Thank you very much.

Best regards,

Margari

Robert Lyon's profile picture
Posts: 431

17 November 2017, 8:06 AM

Hi Margari,

Which type of Authentication on the Mahara end are you using to SSO from Moodle to Mahara? is it MNet (XML-RPC)?

If so what settings do you have for that authentication plugin?

When new users are created each time what are the 'username' value for the new users? This value should be passed in from Moodle - is it a constant value?

If you can provide more information I'll try and work out what the problem could be

Cheers

Robert

Margari León's profile picture
Posts: 8

23 January 2018, 11:07 PM

Hi Robert! I apologise for no answering to you before... I haven´t seen your message....

Well, answering to your question: we followed the manual... and apparently there is only one way to link Moodle and Mahara... I found a quite old manual, are there any new way to do that?

The duplication of the users is like that: user1, user2, user3, and so on....

Thank you for your help :-)

Kind regards,

Margari

 

Robert Lyon's profile picture
Posts: 431

24 January 2018, 8:11 AM

Hi Margari,

If a username / unique name is not being passed in from Moodle it will default to creating the user in Mahara with username = 'user1' (or if that is taken 'user2', and so on).

So first thing I'd check is making sure the correct information is being passed in from Moodle

Mnet is still the default way of hooking Mahara <--> Moodle, but we are in development with getting LTI integration within Mahara so one can hook Mahara <--> Moodle that way.

If your Mahara is 17.04+ you can do Single Sign On (SSO) via LTI but none of the assignment submission stuff.

If it is only SSO you need you could try that out. See http://manual.mahara.org/en/17.04/external/externalapps.html?highlight=lti

Cheers

Robert

Kristina Hoeppner's profile picture
Posts: 3602

24 January 2018, 12:49 PM

Hello Margari,

Do you have any other authentication methods on your site? Your problem sounds a bit like the one described in https://mahara.org/interaction/forum/topic.php?id=5751 or https://mahara.org/interaction/forum/topic.php?id=8143 Can you please check if that is the case and if so, follow the suggestions?

Cheers

Kristina

 

5 results