Forums | Mahara Community

Support /
Admin could not log in after installation


anonymous profile picture
Deleted user
Posts: 2

09 July 2013, 6:04 PM

Hi guys ...

in my holidays  I try to install Mahara to test it and may be use it in school after holiday. I had some problems to bring it to the1&1-Server but as my husband is a software engenieer he finaly got it.

Then I start the installation with the web-based installer. The beginning seems to be okay but then there was an upgrage page where an error accrured.
Suprisingly, after searching for some informations about this problem, next time I called my mahara installation the upgrade seems to be finished.

There were some information that the php-setting about the upload should be changed ... okay ... I would do that later ... with my husband.

Then there was a hint to close the page during update, but as the upgrade was finished I did not do this and the moment. I try to log in, using the admin passwort but when I click on the "login" link in the uper right corner nothing happens.

So I finally said to myself ... okay ... may be close the page ... but that was of cause an error. Now I could not access to my mahara-page once again.

http://mahara.superlehrer.de/

I found this page about "closing" mahara: https://wiki.mahara.org/index.php/System_Administrator%27s_Guide/Upgrading_Mahara#1._Close_your_Mahara_site

But how do I "RewriteEngine on"? The closing happend automatically when I clicked on the button that was on the mahara-page after installation.

Only this page there is a visible page. But logging in is still not possible!?

http://mahara.superlehrer.de/admin/upgrade.php

Please can you give me some help?

My system is a 1&1-Server: Linux, PHP5.3, MySQL5.1 and so onMahara-Version is 1.7.1 ... as far as I know. It is the package-name I donwloaded.

 

Regards, Birgit Lachner from germany.

Aaron Wells's profile picture
Posts: 896

15 July 2013, 4:22 PM

Hi Birgit,

Sorry for the slow response!

It looks like your Mahara site didn't install cleanly. As a result, it's showing you the header which reads "The site is temporary closed for a databes upgrade", but also telling you "Nothing to upgrade. You are fully up to date."

Since you just now performed a clean install and there's no data in the site yet, the simplest thing to do would be to delete everything and install again. Often that fixes installation problems.

If it still doesn't work after that, I can give you some tips on trying to figure out what is going wrong.

Don't worry about those instructions about "closing the site" that you found. That page is out of date... we should probably put a header on the top of it that explains that the information on it may be obsolete.

Cheers,
Aaron

anonymous profile picture
Deleted user
Posts: 2

16 July 2013, 5:24 PM

Hi Aaron,

you were right. Even before you posted it to me, I already deleted the files and copied them once again. After my husband realized to delete the tables in the database the next installation ran without any problem.

I only had a problem with the language-pack ... but found a solution. The description in the wiki is not correct. Can I change it?

It is written to move the language-pack to "langpacks" which seems not to be right. "lang" is the right directory and I need to find the right directory in the expanded pack.

Nevertheless ... thanks for your support, Birgit

Aaron Wells's profile picture
Posts: 896

17 July 2013, 2:25 PM

Please do update the wiki! Laughing You can log in using your mahara.org username and password.

Cheers,

Aaron

Kristina Hoeppner's profile picture
Posts: 3602

19 July 2013, 2:44 AM

Hello Birgit,

I'll flag the wiki page https://wiki.mahara.org/index.php/System_Administrator%27s_Guide/Next_Steps#Install_a_Language_Pack with Son, but think that the directory is correct. We've had a discussion about this a few months ago and I had changed the wiki page to say "lang" because that's the folder where I needed to put the langpacks on my local install, but it was different on a server.

There are also instructions in German on the page. :-)

Cheers

Kristina

 

5 results