Forums | Mahara Community

Support /
Place Feedback Button Not working


02 July 2023, 20:26

Hello everyone. 

                           We've had a very strange issue logged to our dept where im getting reports of The place feedback button on the annotation block is still not working. It should open a dialogue block where you can add feedback but when the button is clicked nothing happens. 

 

Ive had a look in the php/apache error logs and the mahara logs themselves and i cant actually see anything wrong. Were on 22_10 and  just did a git fetch / git status just to make sure we arent behind the repo. Im not 100% sure whats going on.

 

The only think I did notice actually in the mahara directory some of the files are actually owned by root. 

 

root@XXXXXXX:/srv/www/mahara# ls -lht
total 284K
drwxr-xr-x  30 www-data www-data 4.0K Jul  2 09:17 htdocs
drwxrwxr-x  12 www-data www-data 4.0K Jul  2 09:15 maharadata
-rw-r--r--   1 www-data www-data 131K Apr 16 09:32 package-lock.json
drwxrwxr-x 323 www-data www-data  20K Apr 16 09:32 node_modules
drwxr-xr-x   4 www-data www-data 4.0K Apr 16 09:18 test
-rw-r--r--   1 root     root      731 Apr 16 09:18 package.json
-rwxr-xr-x   1 root     root     4.7K Apr 16 09:18 phpstan.neon
-rw-r--r--   1 root     root     1.8K Apr 16 09:18 gulpfile.js
drwxr-xr-x   4 www-data www-data 4.0K Apr 16 09:18 docker
drwxr-xr-x   2 www-data www-data 4.0K Apr 16 09:18 external
-rw-r--r--   1 root     root      17K Apr 16 09:18 Makefile
-rw-r--r--   1 root     root     7.0K Apr 16 09:18 README.md
-rw-r--r--   1 root     root     8.5K Apr 16 09:18 ChangeLog
-rw-r--r--   1 root     root      35K Apr 16 09:18 COPYING
-rw-r--r--   1 root     root      730 Apr 16 09:18 CUSTOMISATIONS-example.md
drwxr-xr-x   3 root     root     4.0K Aug 21  2022 dev
-rw-r--r--   1 root     root     1.6K Jul 17  2022 append_composer.php
drwxr-xr-x  12 www-data www-data 4.0K Jun 16  2021 data
-rw-r--r--   1 www-data www-data  665 Jun  9  2021 phpunit.xml

 

I went into the htdocs folder and some files and dirctories are owned by root too. 

 

Are all files and folders within the mahara directory supposed to be owned by www-data (or is this a security issue) Im not familar with what permissions the mahara directory is supposed to have from a securtiy point of view as this is our production mahara instance. Thats about the only thing i can think of that might be causing it as i cant figure out why the "place feedback" button has stopped working. 

 

Any help or guidance on the matter would be most grateful 

Thanks 

Anthony

 

Robert Lyon's profile picture
Posts: 767

03 July 2023, 9:37

Hi Anthony,

The issue of the dialogue block not opening sounds like it could be a javascript error so the information on the problem may not end up in the error logs but may display in the browser itself.

If you open the developer bar (pressing F12 in Firefox browser) and view the 'Console' tab you might see some errors when clicking the 'place feedback' button.

If you view the 'Network' tab you might also see if any files that failed to load which may cause problems.

Cheers

Robert

 

06 July 2023, 0:23

Hi Robert

                thank you for the suggestion, I did just try that and after I go to the submission group, Click on Submissions, Click on the little eye next to the submission to view it i then get the following error in the console: 

 

download.php:1     GET https://mahara.xxxxxx.xxxx/artefact/file/download.php?file=369&embedded=1&text=480 404 (Not Found)
Image (async)
xe @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
S.parseHTML @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
S.fn.init @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
S @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
eval @ VM6266:2
each @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
loadGrid @ VM6266:2
(anonymous) @ VM6340:13
e @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
t @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
setTimeout (async)
(anonymous) @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
c @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
add @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
(anonymous) @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
Deferred @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
then @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
S.fn.ready @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
S.fn.init @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
S @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
(anonymous) @ VM6340:2
b @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
He @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
append @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
(anonymous) @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
$ @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
html @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
showPreview @ VM6262:1
(anonymous) @ mahara.js,qv=6754.pagespeed.jm.FdbZ-uiUmh.js:1
c @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
fireWith @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
l @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
(anonymous) @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
load (async)
send @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
ajax @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
sendjsonrequest @ mahara.js,qv=6754.pagespeed.jm.FdbZ-uiUmh.js:1
(anonymous) @ index.php?group=1:471
dispatch @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
v.handle @ jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1
VM6344:8 Uncaught ReferenceError: Pieform is not defined
    at eval (eval at <anonymous> (eval at <anonymous> (index.php:1:1)), <anonymous>:8:5)
    at eval (eval at <anonymous> (index.php:1:1), <anonymous>:1:395)
    at Array.forEach (<anonymous>)
    at gridOnAdded (eval at <anonymous> (index.php:1:1), <anonymous>:1:109)
    at eval (eval at <anonymous> (index.php:1:1), <anonymous>:2:581)
    at _gsEventHandler.<computed> (eval at <anonymous> (index.php:1:1), <anonymous>:2:33511)
    at h._triggerEvent (eval at <anonymous> (index.php:1:1), <anonymous>:2:37593)
    at h._triggerAddEvent (eval at <anonymous> (index.php:1:1), <anonymous>:2:37216)
    at h.addWidget (eval at <anonymous> (index.php:1:1), <anonymous>:2:28530)
    at addNewWidget (eval at <anonymous> (index.php:1:1), <anonymous>:3:13)

 

Then i scroll down to the Place feedback hyperlink click on it and nothing happens. This issue affects all submissions in all groups we have in the institution. Im not sure whats wrong. 

 

Any Help would be most appricated. 

Thanks 

Anthony 

Kristina Hoeppner's profile picture
Posts: 4770

18 July 2023, 13:56

Hi Anthony,

In your first post you mentioned you've done a git fetch. Did you make sure to also run 'make css' to update anything relating to the theme / stylesheets / templates? Sometimes look odd when that step is not run, and so I want to make sure that the issue you are seeing is not related to that.

Thank you

Kristina

20 July 2023, 1:36

Hi Kristina

                 thanks for getting back to me i have indeed tried running "make css" it doesnt seem to have made a difference. In fact ive noticed the preview button doesnt seem to work either (see screenshot) on most assignment submissions the dev console gives me this error 

 

index.php?group=38:471 Uncaught ReferenceError: UrlFlashback is not defined
    at S.fn.init.initComplete (index.php?group=38:471:2257)
    at datatables.min.js,qv=6754.pagespeed.jm.PLTf4fljMb.js:1:1817933
    at Function.map (jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1:3536)
    at F (datatables.min.js,qv=6754.pagespeed.jm.PLTf4fljMb.js:1:1817880)
    at Ra (datatables.min.js,qv=6754.pagespeed.jm.PLTf4fljMb.js:1:1803584)
    at datatables.min.js,qv=6754.pagespeed.jm.PLTf4fljMb.js:1:1803423
    at Object.g [as success] (datatables.min.js,qv=6754.pagespeed.jm.PLTf4fljMb.js:1:1796446)
    at c (jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1:28327)
    at Object.fireWith [as resolveWith] (jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1:29072)
    at l (jquery.js,qv=6754.pagespeed.jm.vSq_cOaZon.js:1:79901)

 

 

 

however if i dont use the preview option and open the Submission link i can use the place feedback here and it works. It appears to be entierly localised to the "preview" feature in mahara which seems to be totally broken. 

  • Mahara-Preview.JPG

20 July 2023, 1:39

Just to show you the place feedback button works when i access the submission itself that seems to work just fine. The preview option "the eye" either doesnt open or if it does the feedback button doesnt work at all 

  • Mahara-Preview2.JPG
Kristina Hoeppner's profile picture
Posts: 4770

24 July 2023, 7:45

Hi Anthony,

To summarise: The 'Place feedback' button on an annotation works correctly when you open the actual submitted page. However, it doesn't work when you preview the page? The 'Preview' is only there to give you a quick look at the portfolio, but not to interact with. It's a tiny window and only gives you a quick view. If you want to interact with any links the expectation is to open the page proper and perform actions. Otherwise, we might end up with an inception type of page.

Cheers

Kristina

7 results