Forums | Mahara Community

Mahara/Moodle integration /
Still can't get it to work.


07 July 2022, 21:12

Am running Moodle 3.9

For the life of me I can not get it to talk to my Mahara site.

I worked through this document which seems massively out of date. Which this forum wont let me post a link to so here it is in broken form.  https  :  //  wiki  .mahara  .org  /images  /7/75/  Mahoodle-  updated-  en.   pdf

For the most part I could follow all the steps though had to guess that the root file was my URL??? I have no idea what is meant by the root file on the config file or how to find that.

Is there a better guide?

Mainly though - the problem I  see is in Moodle. Under Site Admin, portfolio's manage portfolios.Mahara eportfolio is disabled and will not activate as it tells me the plug in relies on

  1. Mnet Peers with SSO Published
  2. SSO SP Subscribed
  3. Portfolio services published and subscribe
  4. MNet authentication plug in.

What are these things?????

Advice in the style of an idiots guide would be most appreciated.

Many thanks

Marie

 

 

 

Kristina Hoeppner's profile picture
Posts: 4769

11 July 2022, 12:51

Hi Marie,

Since it seems that you are starting out to set up Moodle with Mahara, please follow the LTI instructions and don't use MNet. The integration especially in regards to the assignment submission is better with LTI because you can initiate an archive, and MNet is on its way out (PHP 8 doesn't even come with the necessary pre-compiled extension once we move to PHP 8 for Mahara).

Thank you

Kristina

2 results