Forums | Mahara Community

Support /
block and file content suddenly disappeared

06 February 2021, 8:33

Hello everybody,

please please please...I need help with this critical issue (approaching final assessment time).

I got a message form one student warning for impossibility to fully load page. Blocks would remain empy. 

When trying to add content to new block error message is "tried to add inexistent file"

ON the file collection page everything seems to be there, with sizes and extensions, but if try to download by clicking on one it says "no permission to open the page" and if tryied to download whole set into a zip file it will list all files in a red block warning files do not exist.

I have approx 100 students panicking for all their work seems to be lost so any advice on what to check, what to look for and what to do would be reeeeeallllly appreciated....





07 February 2021, 3:07

I solved it by restoring a backup. .Just lost the ast few uploads but everything seems to be fine. Will never understand how the whole maharadata directory  had been deleted (Actually transferred int a disk space I do not have access on a shared hosting plan).

Thanks anyway, however as  there are more issues to that site, I am opening a new discussion with a different topic for that purpose.




Kristina Hoeppner's profile picture
Posts: 4771

09 February 2021, 22:30

Hi Adriano,

Great that you could resolve the issue by installing a backup. It seems like the files were either deleted from the server or the permissions on the folder in which the artefacts are stored in the 'maharadata' directly were changed so that Mahara couldn't access the files.

Their references would still be in the database. That's why you would be able to 'see' them, but if you don't actually get the files when attempting to download them, then they don't exist any more. Alternatively, it could also be that t



3 results