Forums | Mahara Community

Open Discussion /

Sha Rahman's profile picture
Posts: 3

20 July 2020, 20:54

Hi, I am using Mahara version 19.10.3 and using the standard Primary school theme. Currently am having a problem with pasting emoticons from another website such as Facebook and also cannot create the emoticons from the HTML editor. I have to go through manual and also discussion but I cannot find any solution for this. If anybody has the experience, really appreciate this. 

Cecilia Vela's profile picture
Posts: 110

04 August 2020, 10:09

Hi Sha,

To know if we can help you we would need a bit more information about the issue.

For example, do you have this problem in the TinyMCE editor only or it also happens with a normal textarea field.

If you go to your profile following User menu-> Profile, the "Introduction" field is a TinyMCE editor. Then if you go to "Contact information" you can see the "Postal address" field is a common textarea. It would be good if we had a sample of the text you're trying to copy.

You mention the Primary school theme, have you tried changing the theme and checking if you still have this problem? That would let us know if this is a theme related problem.



Sha Rahman's profile picture
Posts: 3

09 August 2020, 18:37

Tq Cecilia for your response.

This happens in all text area fields. This is the example of the article that I want to paste 

"Congrats to our Postgraduate Diploma in Education students.. “future proof” teachers in the making.. insha-allah..

In less than 2 months, they came up with an innovative educational products that integrate digital tools or apps in the game-play. They also prepared the montage video, poster and brochures of their products to enter the Sintok International Games and Gamification (SIGG) 2019 held at Dewan Muadzam Shah, UUM yesterday. Out of the 9 products (prototype) produced by this kohort, 2 won GOLD medals 🏅 🏅 with one of it received Best Award, 2 SILVER medals and 5 BRONZE medals.


What an achievement... 👏👏👏"

Where it displays beautifully here.


The problem occurs after saving or displaying the content. Only the question marks appear. Not only that, if I just select the emoticons from the text editor it doesn't work as well. 

For primary school theme, I just make minor changes to the theme without messing with the css or script.

We are now trying to update to version 19.10.4 from 19.10.2 to hope this problem can be solved. 

Cecilia Vela's profile picture
Posts: 110

10 August 2020, 10:19

Hi Sha,

I tried to replicate with a clean install of 19.10.2 but could not replicate the issue.

But to better understand the problem, we could try to see if this happens when saving to DB or when displaying in the browser.

Could you check if the emoticons are save to the DB?

For example if I make a wall post in another user's profile page I should see the text saved in the 'blocktype_wall_post' table on the DB.




Sha Rahman's profile picture
Posts: 3

30 August 2020, 20:35

Thank you Cecillia for your assistance. We have managed to solve the problem by upgrading our database to mb4 charset and using utf8mb4_general_ci collation. We have also upgraded our mahara version to 19.10.4. The problem solved. Tq so much for your response.

Kristina Hoeppner's profile picture
Posts: 4706

28 November 2020, 19:30

Hi Sha,

Thanks for having posted how you resolved this issue. There is a fix for that in Mahara 20.10 if you want to take a look how it's been resolved in Mahara core.



6 results