Forums | Mahara Community

Mahara/Moodle integration /
External Apps url disabled


Lilian HUGUES's profile picture
Posts: 41

29 November 2019, 2:04

Hi folks, 

I'm trying to configure a LTI interaction between mahara (19.04) and a Moodle.

On the LTI external apps configuration, the form ask for the external apps url... Unfortunately, the fields "apps URL" and "callback URI" are both disabled and I can't fill it.

external apps url disabled .png

To you have an idea why and how to turn arround ?

Many thanks in advance for your help.

 

 

Kristina Hoeppner's profile picture
Posts: 4043

29 November 2019, 11:23

Hi Lilian,

You do not need to worry about these two fields. I'll add a ToDo item to add some info to it into the Mahara manual. Since I do not mention them in the manual, they don't require any action. :-)

Best

Kristina

Lilian HUGUES's profile picture
Posts: 41

29 November 2019, 21:58

Hi Kristina,

Many thanks for your answer. It's good to read you ;-).

Actually, the activity in moodle is not properly working : I've got a token error message (cf.screeshot bellow).

Everything seems to be well configured, so I thought it was because of this fields.

Do you have an idea of where it comes from ?

  • The error : token error lti .png 
  • The Mahara config : external apps url disabled .png
  • The moodle config : moodle external apps.png

My best regards,

Lilian HUGUES's profile picture
Posts: 41

04 December 2019, 3:14

Hello,

Does somebody have an idea regarding this issue ?

Regards

Kristina Hoeppner's profile picture
Posts: 4043

04 December 2019, 3:26

Hi Lilian,

Sorry, I can't see from the screenshots what might have gone wrong. Do you use the default LTI setup or do you have some customisations on your site? I'd need to look at all the settings in both Mahara and Moodle step by step to see if anything was missed.

Cheers

Kristina

Lilian HUGUES's profile picture
Posts: 41

05 December 2019, 0:20

Hi Kristina, 

I'm using the default LTI configuration regarding external apps (cf. screeshot).

Users connect on Moodle and Mahara through the OIDC plugin (Auth0 2).

The OIDC connexion is set as parent of the external app in Mahara.

What kind of screenshot or access would you need to have in order to find the issue ?

My best regards, 

Kristina Hoeppner's profile picture
Posts: 4043

05 December 2019, 22:44

Hi Lilian,

We haven't tested the OAuth2 plugin for Mahara (can you please point me to it?) and thus don't know if you can use it as parent for LTI. Can you remove that connection please and see if plain LTI works, i.e. people only have web services listed as auth method and not OAuth2? It might be best to delete your test account from Mahara once you've remove OAuth2 as parent auth from LTI and only then test it so that the auth method will be set correctly.

Cheers

Kristina

Lilian HUGUES's profile picture
Posts: 41

06 December 2019, 21:35

Many thanks Kristina,

I'll do this test and get back to you.

Regards,

8 results