Forums | Mahara Community

Support /
Problem with comments


Joan Forcada's profile picture
Posts: 35

02 October 2019, 8:01 PM

We have an institution with some users. Each user creates their portfolio. Portfolios can write comments.

But the problem we have when writing comments, these aren't registered. 
When you want to edit it, there is no text.

Some solution?

I attached images.
Joan Forcada's profile picture
Posts: 35

02 October 2019, 10:36 PM

Captura3.JPG

Joan Forcada's profile picture
Posts: 35

02 October 2019, 10:38 PM

However, images can be uploaded and displayed.

Joan Forcada's profile picture
Posts: 35

03 October 2019, 1:56 AM

I have this error in error_log: 

Use of undefined constant LIBXML_HTML_NOIMPLIED - assumed 'LIBXML_HTML_NOIMPLIED'

My version is: libxml 2.7.6

Joan Forcada's profile picture
Posts: 35

03 October 2019, 10:44 PM

Tell me something please! 

Robert Lyon's profile picture
Posts: 511

04 October 2019, 8:49 AM

Hi Joan,

Hmm, this is not an issue I've seen before.

Can I get you to check that the comments are actually saved to the database?

I suspect they are not getting saved but only a blank string - it sound like there is a problem with the sanitizing of the comments before saving them to the database.

And the error you are getting sounds like you don't have the libxml package installed on your server.

Can you check if you have libxml installed or not? If you have libxml2 installed can you let me know as that may not be compatible with current Mahara

Cheers

Robert

Robert Lyon's profile picture
Posts: 511

04 October 2019, 8:53 AM

Hi Joan,

You may just need to install php-xml to get the libxml library

Cheers

Robert

Kristina Hoeppner's profile picture
Posts: 3864

06 October 2019, 6:33 PM

Hi Joan,

Please see the bug report for this.

Cheers

Kristina

8 results