Forums | Mahara Community

Support /
User search not working with umlaut / mutated vowel (ü,ä,ö)


Kirsten Konert's profile picture
Posts: 11

20 November 2018, 10:49 PM

Hello,

we have a problem with the user search in Mahara. As soon as a name contains an umlaut (i.e. ü,ö,ä), the entire user list is displayed as a result. So there is no possibility to find a user named e.g. Müller in the search. The problem occurs in both Mahara versions: 17 and 18.
Do you have an idea ?

Many thanks and best regards
Kirsten

Kristina Hoeppner's profile picture
Posts: 3768

23 November 2018, 1:44 AM

Hello Kirsten,

I don't encounter the problem you mentioned on my Mahara 18.10 instance (when I search for a name in the "Search users" search bar at the top of the screen and in the admin area) that contains an ö for example. Is that the search you are using or is that a search elsewhere?

Cheers

Kristina

 

Kirsten Konert's profile picture
Posts: 11

23 November 2018, 2:45 AM

Hello Kristina,
thank you very much for your answer. Exactly, these are the places where I also search / would search. Then this is not a Mahara problem, but rather a problem of the technichal base (e.g. the database)?
Many greetings and see you neyt Friday - in Vienna :)
Kirsten

Kristina Hoeppner's profile picture
Posts: 3768

28 November 2018, 10:08 AM

Hi Kirsten,

It could be a database encoding problem. We use UTF8 but you might have a different encoding. Please check with your IT support on that.

Cheers

Kristina

 

Kirsten Konert's profile picture
Posts: 11

28 November 2018, 11:53 PM

Hi Kristina,

we use UTF8 .... :( Right now, we have no other idea what the reason might be.

Best wishes

Kirsten

Kristina Hoeppner's profile picture
Posts: 3768

08 December 2018, 8:21 AM

Hello Kirsten,

I'm afraid I don't either at this moment. Has the encoding changed recently or did you always have this problem?

Cheers

Kristina

 

6 results