Forums | Mahara Community

Mobile Mahara /
Problems with mahara mobile


Ralph Ballier's profile picture
Posts: 98

16 April 2018, 9:41 PM

Hello,

I want to use Mahara with "mahara mobile".

I downloaded the app for Android. "mobileapi" in Mahara is activated. Manual token generation is switched off.

When I enter the URL, username and password in the app, nothing happens at all.

 

I turned off the firewall.


What could be the problem? I also find in the log files no evidence. Maybe I search in the wrong logfiles. Where would I have to find something? Does the app have a debug mode?

Kristina Hoeppner's profile picture
Posts: 3739

17 April 2018, 12:33 PM

Hi Ralph,

Is the Mahara site that you want to connect to running on https? If it is, can you connect to Mahara on a different device?

Can you connect to demo.mahara.org via Mahara Mobile from your phone?

Thanks

Kristina

 

Ralph Ballier's profile picture
Posts: 98

19 April 2018, 7:04 PM

Hello Kristina,

in the meantime, I have found the following line in the SSL log file of the Apache (not in the error log):


79.194.63.70 - - [19 / Apr / 2018: 08: 46: 13 +0200] "GET /modules/mobileapi/json/info.php? HTTP / 1.0" 200 1012 "-" "Mozilla / 5.0 (Linux; Android 8.0.0; SM-G950F Build / R16NW; wv) AppleWebKit / 537.36 (KHTML, like Gecko) Version / 4.0 Chrome / 65.0.3325.109 Mobile Safari / 537.36 "


It appears when I click on "Next" on the phone after entering the URL. The subsequent attempt to log in is not found in the logfile.


Yes, https is installed. If I enter the same address in the browser on the same mobile phone as before in the mobile app, then I immediately get access to mahara and there are many lines in the logfile to see.


In "https://demo.mahara.org" I can log in with the app.


Often I have progressed through systematic testing in such cases. But unfortunately I know too little about the app. You can not set anything there, such as a debug mode.

Ralph

Kristina Hoeppner's profile picture
Posts: 3739

20 April 2018, 4:40 PM

Hello Ralph,

Thank you for the testing and the investigation. Now the question is: What's different between the demo site and your site.

We'll have to check if we can find anything.

Cheers

Kristina

 

Ralph Ballier's profile picture
Posts: 98

20 April 2018, 11:53 PM

Hello Kristina,

I completely re-installed mahara on another server. Now the registration via the mobile app works.

If you compare the two installations (old and after upgrade: mahara.osz-lise-meitner.eu, new: mahara-test.schule.de), then you can already see a difference in the opening screen, although both have the same version. Strange.

Do I get the content and users from the old installation over to the new installation? So far, it is only one group, one institution and ten participants.

Kristina Hoeppner's profile picture
Posts: 3739

22 April 2018, 11:08 AM

Hello Ralph,

Great that your new site works. I can't get to the test site as it says 403 forbidden. It may only be available from within your network.

You can set up the old database for the new site or copy the data and files over. There are some instructions on the wiki for that.

Cheers

Kristina

 

Ralph Ballier's profile picture
Posts: 98

22 April 2018, 10:09 PM

Hello Kristina,

strange, for me both URL work and I'm not on the local network.

I would rather not copy the database because the error must be somewhere.

greeting and thanks


Ralph

7 results