Forums | Mahara Community

Support /
Unable to export portfolio to LEAP2A or HTML


02 February 2018, 11:11 PM

Hi everyone,

Since we changed servers I would like to export all the templates portfolio's I made to the new Mahara server. But when I try to so so, it seems to get stuck. I don't get an error message but it just keeps telling me to 'Wait while my export is generated'. It's been half an hour now so I think it might be a bug. Does anyone know what I can do about this?

 

 

Kristina Hoeppner's profile picture
Posts: 3507

03 February 2018, 8:02 PM

Hello Melissa,

Please take a look into your error log and see if there are any messages in there relating to your export when you attempt it.

Are all the artefacts that you reference on the page still on the site? That might cause the export to hang if it can't locate a file and it's still referenced say in a text box rather than in a file block from which it would be deleted automatically.

Cheers

Kristina

 

Chris Poette's profile picture
Posts: 3

23 March 2018, 5:46 AM

Everyone,

I have the same exact problem.  Upon trying to export to HTML or LEAP2A it appears to be stuck.  I am running version 17.10.2.  I tried upgrading to 17.10.3 in hopes it was a specific bug but still get the same problem.  I looked at the mahara error logs and nothing is reported.  Any help would be appreciated.  Thank you.  

Robert Lyon's profile picture
Posts: 393

23 March 2018, 2:57 PM

I wonder if there is some underlying program missing like php-zip that causes things to hang?

Does export work in older versions of Mahara on that server?

Cheers

Robert

 

Chris Poette's profile picture
Posts: 3

24 March 2018, 5:40 AM

Robert,

Thank you for your reply.  That was one area that slipped my mind.  I did however recently upgrade PHP to version 7.1 from 5.6.  This was done due to Moodle running on the same server.  I did check my PHP modules and zip is installed.  For a brief second you can see a creating zip file and thats where we seem to hang forever.  The system requirements for Mahara does say PHP 5.6 or above so I am assuming PHP 7.x is ok to run.

Robert Lyon's profile picture
Posts: 393

26 March 2018, 10:14 AM

Hi Chris,

This problem looks to be for PHP 7.1+ and Mahara as I don't get the problem on PHP 7.0 - see https://bugs.launchpad.net/mahara/+bug/1757330 for more info

I believe I've found a solution for the problem and have made a fix for it - see https://reviews.mahara.org/#/c/8712/

From my initial tests it works for PHP 7.0 and 7.1+

We hope to get this fix merged very soon

Cheers

Robert

Chris Poette's profile picture
Posts: 3

27 March 2018, 5:39 AM

Robert,

Wonderful.  I am so glad this was found and submitted as a bug.  I did apply this patch and it did fix the problem.  I was currently running 17.10.2.  Thank you so much for your help.

Kristina Hoeppner's profile picture
Posts: 3507

27 March 2018, 2:01 PM

Hello Melissa,

Does the fix that Robert make also fix your export problem? If not, please let us know what your PHP version and operating system are.

Thank you

Kristina

 

8 results