Forums | Mahara Community

Mobile Mahara /
Mahara Mobile: Unable to sync data with the server


Ralf Klawitter's profile picture
Posts: 5

28 January 2018, 6:53 AM

Hello from Germany,

I've tried to connect Mahara Mobile 1.4.0 (Android) to my Mahara-Installation (17.10, hosted by a provider, SSL) an I get "Unable to sync data with the server"

- in the administration menu / extensions I enabled Mobile Apps API

- after doing this, Web services are enabled (incoming) with Protocol REST

- After the first try, my Android Device was listed under my user-account / settings /apps

So I suppose that my login was successful. Do you have any hints for me? Is there another log except the apache log?

Thank you very much!

Ralf

P.S.: Mobile login to demo.mahara.org was successfull!

 

 

 

Ralf Klawitter's profile picture
Posts: 5

31 January 2018, 10:31 AM

 

"GET /module/mobileapi/json/info.php? HTTP/2.0" 303 - "-" "Mozilla/5.0 (Linux; Android 6.0; RAINBOW Build/MRA58K; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/63.0.3239.111 Mobile Safari/537.36"
x.x.x.x - - [27/Jan/2018:16:44:51 +0100] "GET / HTTP/2.0" 200 5134 "-" "Mozilla/5.0 (Linux; Android 6.0; RAINBOW Build/MRA58K; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/63.0.3239.111 Mobile Safari/537.36"

x.x.x.x - - [27/Jan/2018:16:45:29 +0100] "POST /module/mobileapi/json/token.php HTTP/2.0" 200 70 "-" "Mozilla/5.0 (Linux; Android 6.0; RAINBOW Build/MRA58K; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/63.0.3239.111 Mobile Safari/537.36"
x.x.x.x - - [27/Jan/2018:16:45:29 +0100] "POST /webservice/rest/server.php?alt=json HTTP/2.0" 200 551 "-" "Mozilla/5.0 (Linux; Android 6.0; RAINBOW Build/MRA58K; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/63.0.3239.111 Mobile Safari/537.36"

x.x.x.x - - [27/Jan/2018:16:46:03 +0100] "GET /module/mobileapi/json/info.php? HTTP/2.0" 200 161 "-" "Mozilla/5.0 (Linux; Android 6.0; RAINBOW Build/MRA58K; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/63.0.3239.111 Mobile Safari/537.36"

x.x.x.x - - [27/Jan/2018:16:46:34 +0100] "POST /module/mobileapi/json/token.php HTTP/2.0" 200 70 "-" "Mozilla/5.0 (Linux; Android 6.0; RAINBOW Build/MRA58K; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/63.0.3239.111 Mobile Safari/537.36"
x.x.x.x - - [27/Jan/2018:16:46:34 +0100] "POST /webservice/rest/server.php?alt=json HTTP/2.0" 200 551 "-" "Mozilla/5.0 (Linux; Android 6.0; RAINBOW Build/MRA58K; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/63.0.3239.111 Mobile Safari/537.36"

Kristina Hoeppner's profile picture
Posts: 3418

03 February 2018, 8:11 PM

Hello Ralf,

Sorry, I can't think of what it could be. Can you please try turning your web services off (easily done if you only use Mahara Mobile, but be more careful if you use others) and activate the mobile APIs again via the "Extensions" page? I've seen a problem with them being properly activated on a couple of client sites a while ago and re-activating them solved the problem.

Do other users at your institution experience the same issue or is it just you?

Cheers

Kristina

 

Ralf Klawitter's profile picture
Posts: 5

04 February 2018, 2:33 AM

Hello Kristina,

all users are concerned by the issue - but there are only two of them, because we just started evaluating mahara for our institute :)

I turned the Web-services on and off and activated the mobile api several times while I searched the reason of this issue. Perhaps this caused a misconfiguration. Tomorrow, I'll try a completely new install and I'll let you know the results!

Thank you!

Prost ;)

Ralf

Ralf Klawitter's profile picture
Posts: 5

04 February 2018, 9:07 PM

Hello Kristina,

I reinstalled Mahara (on a shared host) - same issue.

This time, I didn't change any presets (language pack, name of journal etc.). I only activated the mobile api.

I used local login, this seems to work: settings/apps shows my mobile devices. Is there any logging where I can search what happened (or not happened...)?

 

Thank you, bye

Ralf

 

5 results