Forums | Mahara Community

Open Discussion /
White page appearing when clicking on EDIT PAGE


Lisa Ransom's profile picture
Posts: 10

25 October 2017, 1:00 PM

We have a strange instance, where a student has created a page and saved it, and when they go to EDIT the page, a white screen overlays from the right hand side.

The only way we can get rid of this white overlay, is to double click at the top left hand corner - this then takes us into the edit mode.

We have tried removing and replacing each module on the page, the page layout etc but nothing seems to make a difference.


Has anyone come across this and if so, can you offer a solution please?

 

Thanks

Lisa Ransom

AUT, Auckland

Lisa Ransom's profile picture
Posts: 10

25 October 2017, 1:53 PM

Forgot to add - we have tried all browsers - getting the same issue on all

Kristina Hoeppner's profile picture
Posts: 3366

26 October 2017, 8:18 AM

Hello Lisa,

Is it correct to assume that this came after you made an update to your site? It would be good to check what has changed if you didn't have the issue before.

Also, this might be a custom issue on your site as we don't have an edit button in the top left corner. Might it have anything to do with a custom theme? You could also check if there is anything in the error log.

Cheers

Kristina

 

Jawyei Wong's profile picture
Posts: 16

26 October 2017, 11:21 AM

Hi Kristina

 

This is the first time this has happened. When the student copies the page it seems to be ok. The issue is when the page is in 'edit mode', the overlay for when you are editing a block slides in but does not seem to load. My suspicion is that the page might have had a rogue block or something along those lines. There are no errors report when going into the page. I cannot check if it is the theme since that will affect the overall site.

 

Jawyei

Kristina Hoeppner's profile picture
Posts: 3366

26 October 2017, 11:04 PM

Hi Jawyei,

I'm not aware of having had this issue before. Can you export the page into your testing environment and perform some more testing there to isolate the issue? It sounds like a JavaScript problem. Is there anything that you can see in the dev tool JS error console?

Cheers

Kristina

 

Jawyei Wong's profile picture
Posts: 16

27 October 2017, 11:25 AM

Hi Kristina

 

I have exported and imported this into our stage environment and still get the same issue. I changed the theme to raw and still the same. The js error console on Chrome only says:

 

tablerenderer.js?v=75:14 [Violation] Avoid using document.write().
(anonymous) @ tablerenderer.js?v=75:14
2tablerenderer.js?v=75:14 [Violation] Parser was blocked due to document.write(<script>)
(anonymous) @ tablerenderer.js?v=75:14

 

The student's has made a copy of the page and seems to be ok so not really important but still a weird 'thing'.

 

Jawyei

6 results