Forums | Mahara Community

Mahara/Moodle integration /
.../auth/mnet/land.php was not found on this server Mahoodle problem

Niklas Frost's profile picture
Posts: 24

17 March 2017, 4:50

Scenari0:  A testserver Moodle 3.2.2 is to be Mahoodled with  a testserver Mahara 16.10. 


But when a logged in Moodle user with a manual account tries to  sso over to Mahara it do not work.

So we have done something wrong  - we gets this error message :

"..../auth/mnet/land.php was not found on this server


I think we have configured the Mahara-peer-profile in Moodle to MNet a Moodle site instead of a Mnet Mahara site.

However I can't  verify that is the case in the that hostprofil i created - it just doesn't give the info in the profile when created.

But it would be logical since  the error message ask for a file not existing in Mahara.


So we deleted the old  Maraha peer-hostprofile in Moodle - and tried to redo a new host profile.  But Moodle says it is deleted but still also claims that the hostname is taken - by the deleted hostprofile(!)


And I can't delete that profile or change in Moodle.  Anyone  knows somethings about this?!

Best regards Nicke

Kristina Hoeppner's profile picture
Posts: 4043

19 March 2017, 14:23

Hello Niklas,

You may need to delete it entirely from the Moodle database. Those old keys seem to be very persistent in Moodle and when it finds a site that you had already used, it rather wants you to re-activate the old key though you should still be able to say that you'd like to create a new peer rather than using the old one. If your Moodle doesn't let you do that and you don't want to delete the key from the DB, maybe you can change the application type from Moodle to Mahara in the Moodle DB?




Benjamin Kahn's profile picture
Posts: 1

04 July 2019, 6:08

Hello, I was having the same problem and wanted to post the solution that worked for me. As Niklas said I initially accidentally left the Mnet host as Moodle rather than Mahara. Even though I changed this setting on the web form, and tried to delete and create a new profile, it still seemed to be "stuck" as Kristina says and always tried to find the non-existent PHP file in Mahara. When I tried to recreate the profile I would get a message that it already existed and that I should change the profile setting for "Deleted?" from yes to no. Not helpful.

So I went into the database and made the following change (note my Moodle database prefix is mdl):

First, look in the mdl_mnet_application tableThere should be two entries, one for Moodle and one for Mahara. Make a note of the ID for Mahara. In my case it was 2.

Then, in the md_mnet_host table and, change the application id field of your messed up mnet host to the correct value for mahara , as specified in the mdl_mnet_application table. in my case, I changed from 1 (moodle) to 2 (mahara).

3 results