Forums | Mahara Community

Support /
Why can't Tutors open Group submissions?

10 May 2016, 1:21 AM

We have Mahara 15.04 and although staff assigned the 'Tutor' role in their Groups can see a list of all the submissions made to the Group, when they click on any of the submissions listed to open it, they see this message:

"Access denied

You do not have access to view this page.
Access denied"


Yet when you look at the Group's settings under "Allow submissions" you see that:

"Members can submit pages to the group that are then locked. These pages cannot be edited until they are released by a group tutor or administrator."

This seems to imply that Tutors should be able access/open submissions to the Group in the same way those with the 'Admin' role can, because as far as I know one needs to be on a Page in order to Release it.

Hence, can you please advise us how to fix this problem so that our 'Tutors' can open submissions to their Groups?

Thank you,


eLearning Adviser

University of Roehampton, London


Ghada El-Zoghbi's profile picture
Posts: 122

10 May 2016, 8:16 PM

Hi Karen,

That must be frustrating. I hope I can help.

I've had a look through the code and the most likely scenario is perhaps the owner of the submitted page is suspended.

Can you please check the status of the user who owns the submitted page?

Please let me know how you go.








10 May 2016, 10:07 PM

Hi Ghada,

Thank you so much for replying to my cry for help. However, it's not just one student or a few students whose submission can't be opened by those with the Tutor role in a Group, it's all the student submissions to the group which can be seen listed, but can't be opened by the Group's Tutors. I have checked a few of the student's account settings and none of them are suspended. So unfortunately, we still have a problem :(.

Can you think of anything else that I might try?

Thank you again,


P.S. A bit of background info in case it's relevant:

Our institution's Mahara installation plugs into Moodle 2.8 and our Mahara users login to Moodle to access Mahara 15.04.

Ghada El-Zoghbi's profile picture
Posts: 122

10 May 2016, 11:37 PM

Hi Karen,

Thank you for the information.  That's another area in the code where this error is thrown.

If the user is coming into Mahara via SSO MNET with Moodle, it checks the MNET token that Moodle calls the page with.

That is, the tutor's authentication method is the XML-RPC auth.

I think the original logic is tutors (and teachers ) will view the page via Moodle when they grade the assignment submission.

But in your scenario, the students are not submitting the assignment to Moodle but rather to a group.

I need to confirm that is the case with the Mahara team. This may be a bug in Mahara.

As a work around for the time being, can tutors log into Mahara perhaps via LDAP - if you have that set up in your organisation. You'll need to update their authentication method to LDAP instead of XML-RPC. Of course, this may not be possible for you.

Or, create temporary manual accounts for the tutors. Not ideal.

I'll confirm the scenario tomorrow.

Ghada El-Zoghbi's profile picture
Posts: 122

11 May 2016, 12:33 PM

Hi Karen,

I've setup a dev environment with Moodle 8 + Mahara 15.04 with MNET.

I tested it with the Mahara submission plugin (assignsubmission_mahara) version 2015021001.

Unfortunately, I can't replicate the error.

Are you able to provide some error logs (only the relevant errors)? They may have more details as to what is causing the issue.

Also, please note that Moodle 8 has just come out of support (ended on 9 May). I would recommend upgrading as there have been great advances with the Mahara submission plugin.




Kristina Hoeppner's profile picture
Posts: 3864

11 May 2016, 2:22 PM

Hello Karen,

Thanks for your post. :-)

As Ghada mentioned, it would be good to have the error message that is stored in the error log when a tutor clicks on a submitted page. The message you see on the screen doesn't provide much of the why and sometimes there is more in the error log.

Also, does this happen only in one group or across the board? It would be good if you set up a test group with an admin, tutor and a regular member, then submitted a portfolio as the regular member and then tried to view that as tutor. Do you get the same error message? If that were the case, we'd need to take a look at your instance directly I think to verify the group settings at minimum and perform some tests.




13 May 2016, 3:00 AM

Hi Kristina and Ghada,

I've ascertained when a Group Tutor can or cannot see a submission made directly to the Group in Mahara (NOT in/via Moodle) and I've tabulated my findings below:

If a submission was made: "Allow archiving of submissions" was: Tutor access:

Hence the question now is, why does changing the "Allow archiving of submissions" setting from its default position of OFF at any point during the life of a Group affect the access Tutors have to submissions made on that Group?

Can this problem be fixed?

Thank you ever so much for your efforts to resolve our problem so far and I hope that this data will enable you to help us further.

All the very best,


13 May 2016, 5:02 AM

P.S. With reference to my last post made earlier today, my findings are applicable across all Groups in Mahara and all users assigned the role of 'Tutor' in a Group, not just one Group or a particular user with the role of 'Tutor'.

Kristina Hoeppner's profile picture
Posts: 3864

13 May 2016, 8:49 AM

Hello Karen,

Thank for doing more testing. I still can't replicate the issue you are having. Mahara 15.04 behaves for me as expected.

Are you testing in the same group or different groups? Can you please go into the block config of the "Group pages" block and make sure that submitted pages are displayed and click the "Save" button even if the setting was correct? There is an issue that this block option isn't displayed directly. We are in the process of fixing that:

Does saving the settings again make a difference? If not, we'd need to look at your instance.




14 May 2016, 12:18 AM

Hi Kristina,

To answer your question,  I'm testing in different groups with different Tutors and submissions. But, all the groups I'm testing that have the problem whereby Tutors CAN see the list of submissions but when they click on one to open it, they see the "Access Denied" message displayed, are groups in which I changed the "Allow archiving of submissions" from OFF to ON (and then OFF again, I after I discovered the problem).

Following your instructions, I've just gone into one of these groups and clicked on the Save button even though the setting is correct, but unfortunately it didn't make any difference.

The tutor still can't open pages submitted either before or while the "Allow archiving of submissions" setting was set to ON but can open pages submitted after "Allow archiving of submissions" was switched OFF.



13 results