Forums | Mahara Community

Support /
Downloading Version 15.10.0

Rick Johns's profile picture
Posts: 11

06 November 2015, 4:56

Hi everyone, I have just been doing a new install of Mahara 15.10.0 on a dedicated server and found installation problems using the "zip" version of the download from the Mahara site.

When you extract the files it sets the permissions to 775 for folders and 664 for files and this gives server errors when you try to run the install.

My ISP was helpful in running a bulk permission change to 755 and 644 respectively and everything worked fine.

I subsequently found that if you download the "tar.gz" version from the Mahara site everything works fine first time around (with the correct folder and file permissions).

Has anyone else had this problem or is it just me?? Not sure if this is a bug or something I am not doing right.

Rick Johns

anonymous profile picture
Account deleted
Posts: 18

06 November 2015, 22:25

Hi Rick,
I have installed the zip version too but It worked well. It could be a mistake of the FTP client.
Everything fine with FileZilla 3.14.1.Hope this helps
Aaron Wells's profile picture
Posts: 896

10 November 2015, 14:22

Hi Rick,

This is a limitation of the "zip" file format. While the "tar" format can store Unix-style file permissions, zip cannot (without custom extensions, anyway).

Even if you're using a tar file, it's a good idea to verify that the files have the correct permissions anyway. This is not an issue unique to Mahara, but to web hosting generally. :)



3 results