Forums | Mahara Community

Support /
http https iframe nightmare


anonymous profile picture
Account deleted
Posts: 5

09 September 2015, 2:34

Hello

We upgraded to 15.04.3 a couple of weeks ago. all seems to be going nicely until I tried to add in allowed iframes.

I have added SoundCloud using soundcloud.com/ and w.soundcloud.com/player/ as per this page: https://wiki.mahara.org/index.php/Allowed_iframe_sources and various other permutations with this and flickr too.  To no avail.

When I try to embed soundcloud, I can't even get out of the editor but I get this message: "Invalid URL"

I am really confused by all the different types of embed methods, what I do know is for some weird reason my mahara is http and not https so I am wondering as most of these things I can embed are https, is this the root of the problem.

This would be a huge win for us if we could embed content easily, it would be an even bigger win if we could embed one drive content but that is a story for another day. 

Any help would be really appreciated.

Thanks

Tina Rowe.

anonymous profile picture
Account deleted
Posts: 5

09 September 2015, 4:02

ignore me.  I managed to get the links working in the end

T

Kristina Hoeppner's profile picture
Posts: 4730

09 September 2015, 8:06

Hello Tina,

Great that you could get the links to work. Was there anything else that you needed to do? The only thing I could think of would be to check your security settings that you allow external resources in HTML: http://manual.mahara.org/en/15.04/administration/config_site.html#security-settings

Cheers

Kristina

 

Michael Ford's profile picture
Posts: 2

09 September 2015, 19:26

Hi Kristina,

We've been having similar problems with the Allowed iframe sources in 1.10. Am I right in thinking we can only use http, or is there a way of adding https sites as well?

Many thanks for your help.

Michael Ford

Kristina Hoeppner's profile picture
Posts: 4730

09 September 2015, 21:03

Hello Michael,

You don't specify the protocol for the iframe sources. It adds that by itself. Do you have the external HTML option that I mentioned earlier turned on for your site?

What iframes do you have a problem with and do you have http or https for your site?

Thanks

Kristina

 

Michael Ford's profile picture
Posts: 2

09 September 2015, 23:16

Hi Kristina,

We have the eternal HTML source enabled, and http iframe sources are working as expected. However, our media server uses https and we haven't found a way of allowing this as an iframe source since the http protocol is added automatically.

I feel I must be over-looking something as I would imagine there are many users with an http Mahara wishing to allow an https iframe source?

Many thanks

Michael

Kristina Hoeppner's profile picture
Posts: 4730

10 September 2015, 16:42

Hello Michael,

https sites should work. I just embedded a song from Soundcloud (w.soundcloud.com for your iframe sources). The iframe code is with https and it embeds just fine on my non-https site. Is it possible that you send me the embed code to one of your files on your media server by message so I can try it out?

Cheers

Kristina

 

Robert Lyon's profile picture
Posts: 757

16 September 2015, 10:18

Hi Michael,

There is indeed an problem with how the iframe embedding code is currently working. See the iframe bug report about it. The problem is when the Mahara site's url protocol does not match the iframe's url protocol, and what the external site can handle.

Most sites nowdays are set up to deal with both http and https requests and redirect/return data accordingly. But some sites only have one of the protocols set up.

We need to adjust Mahara to allow for this scenario.

Cheers

Robert

8 results