Forums | Mahara Community

Support /
Collection block types not showing after import


Robin Leung's profile picture
Posts: 12

09 June 2015, 11:56 AM

I've been testing the export/import feature out with a server running Mahara 1.8.1 (where I'm doing the export) and Mahara 1.10.2 (where I'm doing the import).

From a technical stand point, the import should work perfectly fine since I'm importing from older install into a newer install.

There are "collection" blocks on pages that do not get restored for some reason. The error message I get are these:

  •  [DBG] 56 (blocktype/lib.php:791) Artefacr not found when rendering a block instance. There might be a bug with deleting artefacts of this  type? Original error follows:
  • [DBG] 56 (blocktype/lib.php:792) Collection with id 5266 not found
  • [DBG] 56 (blocktype/lib.php:808) Cannot render block title. Original error follows: Collection with id 5266 not found

When I go into "Edit the page", I get slightly different error messages:

  • [DBG] 02 (blocktype/lib.php:671) Cannot render block title. Original error follows: Collection with id 5266 not found
  • [DBG] 02 (blocktype/lib.php:692) Artefact not found when rendering a block instance. There might be a bug with deleting artefacts of this type? Original error follows:
  • [DBG] 02 (blocktype/lib.php:693) Collection with id 5266 not found

I would need to edit the page and edit the block to once again select the correct collection before it will display in the page correctly.

Any ideas on why this is not importing over correctly? I am suspecting the block id numbers are not matching up for some reason.

 

 

 

Kristina Hoeppner's profile picture
Posts: 3400

15 June 2015, 7:54 AM

Hello Robin,

Do you mean the "Navigation" block? Are you exporting and importing and entire portfolio or only one collection or a couple of collections? The error message says that a collection can't be found so I'd look there first. If you can import an entire portfolio and not only a portfolio that may be the cause of the problem.

Cheers

Kristina

 

Kristina Hoeppner's profile picture
Posts: 3400

15 June 2015, 10:47 AM

Hi Robin,

Actually, it seems that this is a known bug as per https://bugs.launchpad.net/mahara/+bug/1333424

It's not a trivial fix and of medium priority. If you wish to speed up its development, you can either fix it yourself or sponsor to have it fixed. If you are interested in the latter, please send me a message.

Cheers

Kristina

 

3 results