Forums | Mahara Community

Mobile Mahara /
Unable to upload a blog post - Maharadroid

08 April 2015, 13:10

I tried it a while back with beta version of Maharadroid. Now, it's out of beta phase so I tried again without success. I cannot upload a blog post even though I can upload a file.

I tried with 2 different machines (Samsung S5 and Nexus 7) on 2 different Mahara instances with 3 accounts in total. I always get the same error message :

"Failed to uload 'Failed to save file' "

What am I doing wrong?

The sync URI seemed weird without the http://... so I added it but it had no effect.

Thanks for your help



Aaron Wells's profile picture
Posts: 896

09 April 2015, 12:05

Hi Stephane,

Thanks so much for trying out the new version of MaharaDroid! :)

The "Upload URI" and "Sync URI" should just be partial paths. In fact, unless you've heavily hacked your Mahara site there should be no need to change them from their defaults of "/api/mobile/upload.php" and "/api/mobile/sync.php". I'll probably just hide those settings in the next iteration of MaharaDroid, since there will almost never be a need for a user to edit those.

I noticed some difficulty creating a blog entry as well, although I didn't see that specific "Failed to uload 'Failed to save file'" message. My experience was that MaharaDroid said it had successfully uploaded the blog entry, but I saw no blog entry in my Mahara account.

It did work after I set one of my blogs as the default, though.

What version of Mahara are you using? And would you mind posting all your MaharaDroid preferences here? That might help me replicate the problem.

I've moved this project to Github for the time being. So, I've filed a bug report about your issue there:



2 results