Forums | Mahara Community

Mahara/Moodle integration /
Mahoodle-cannot login


anonymous profile picture
Account deleted
Posts: 5

25 August 2014, 5:12

Hi

My moodle (2.71) and mahara (1.9) sites are set up for integration. In moodle I click the  icon which takes me to the mahara site but gives this message:

'Sorry, we could not log you into UGS Mahara at this time. Please try again shortly. If the problem persists, contact your administrator.'

Now when I then manually login to mahara I can see that the account has been copied as a new user has been create and there is a login time. So the link seems to be working and if in mahara I 'login as my new user'  the link back to moodle works.

The moodle instance is in VPS on hostmonster and the mahara on hostpapa as shared hosting.

Please help I am out of ideas.

PS Moodle/google SSO working great.

 

Thanks

 

Michael

anonymous profile picture
Account deleted
Posts: 5

25 August 2014, 7:10

I just discovered that student users can use the moodle/mahara integration but I cannot!

I deleted my mahara user account and checked the moodle permissions then tried again but was still not able to integrate. I can however login in to mahara internally.

Any ideas?

Michael

Anita Bridgman's profile picture
Posts: 13

27 August 2014, 11:50

Hi Michael

In your Mahara user profile, try changing your Authentication method to be the method that uses SSO from your Moodle site.  You should still be able to log in directly to the site even if you change this.

For some reason a few of us need to have it set that way for SSO to work from MDL-->MAH.  When I was testing this it seemed that if a user had a change to their Authentication method, then for SSO to work, the Authentication method has to be set to the method used by Moodle.  I didnt look into it much past this as the impact was extremely small for our user base.

Hope this helps.

Cheers

Anita

Kristina Hoeppner's profile picture
Posts: 4751

31 August 2014, 14:37

Hi Michael,

There are a few reasons for why you may not be able to log in via Moodle.

  1. As Anita mentioned, check what your authentication method is in Mahara. If you are on "internal" authentication, you can use the normal Mahara login form, but not MNet. As she said, you'd need to change your authentication method to the Moodle one. AND you will need to set the "username for external authentication" to your Moodle username.
  2. Check the MNet settings on Mahara. If you want new users to register via Moodle, you'll need to have clicked the "We create accounts" option.
  3. In the Mahara institution settings, check that you have not yet reached the maximum number of allowed accounts.
  4. If you could log in to Mahara via Moodle but did not end up in your existing account, I suggest you delete the account that was just created and go back to option number 1 and set the authentication method and the remote username.

Cheers

Kristina

 

Dan Tina's profile picture
Posts: 20

01 October 2014, 1:31

Hi Kristina,

I am having the same problem with authentication using Mahoodle - I keep getting this message:

Sorry, we could not log you in. Sorry, we could not log you into XXXX at this time. Please try again shortly. If the problem persists, contact your administrator.

Came across these posts while looking for solution and I've carried out the relevant checks suggested (only 1-3 was applicable) but still getting the error.  Any idea why? We've got Moodle 2.5 and Mahara 1.9.2 installed; both on the separate Apache webservers.

Regards,

Dantina

 

anonymous profile picture
Account deleted
Posts: 33

01 October 2014, 13:59

Ensure that both the Moodle and Mahara servers have the same time. If you are using something like Debian then install NTP on both. Mnet is time critical a clock discrepancy >3 seconds and "Sorry we can't connect."

If you are using Window$ then install Tardis.

Dan Tina's profile picture
Posts: 20

02 October 2014, 21:41

That did it!  Installed and configured NTP and the problem went away.

Thanks a lot John.

Dantina.

anonymous profile picture
Account deleted
Posts: 2

19 February 2015, 4:27

Hi, we're now having this same problem.

When I try to log in to Mahara through Moodle, I get the message:

Sorry, we could not log you into XXX at this time. Please try again shortly. If the problem persists, contact your administrator.

I've also tried logging in manually and can't get in that way either. From what I remember, we may have disabled that option. I also tried with our test account and couldn't log in either way. From what I remember, 1-3 are set up the way you specified.

I'll also note that I haven't had any trouble logging in in the past, this has only been an issue in the last day or so, and I didn't make any adjustments that might have affected this as far as I'm aware.

We're using Mahara 1.9 and Moodle 2.71. Our servers are hosted by Moodlerooms but they've told me they aren't able to do anything unless it's something set up incorrectly on the Moodle side.

Any suggestions would be welcome, thanks!

19 February 2015, 5:11

Hi James,

As John in a few message before pointed out, in 90% of the SSO problems the clock is faulty. If your two servers don't have the same time (a diff < 3 is ok) the SSO doesn't work.

So install a NTP service on each server and config them so they have the same time.

Try to SSO again. It should work.

Regards,

-dajan

Kristina Hoeppner's profile picture
Posts: 4751

01 March 2015, 21:42

Hello James,

It would be good if your hosting provider checked the error logs on both Moodle and Mahara for some more information that could provide some insight into the problem. Usually, the error codes in the error log are a bit more explicit.

If it is a time sync issue, which it might be if the connection suddenly stopped working without any other change, it is usually solved by simply restarting the server. We usually restart the Moodle server in this case (often they are hosted on different servers) and that has always resolved any time sync issues.

Cheers

Kristina

 

13 results