Forums | Mahara Community

Developers /
Displayer for Open Badges


Beth  Klingner's profile picture
Posts: 10

17 July 2014, 8:40 AM

Hi All,

I'm having the same issue of not being able to show badges from my backpack after I drag the content block to a page.  I'm using a test version of 1.9. Does anyone have a solution?  I'm excited about getting our users displaying badges on their pages.

Thanks,

 

Beth (from Pace U.)

 

17 July 2014, 9:55 AM

Hello Beth

The plugin is working fine on my 1.9 and 1.10 development versions.
First I recommend you never use a test version when the final official release is out. The actual mist recent version is 1.9.1

Second as usual it is impossible to tell you what is not turning right on your side without any further information. Please have a look at the server's errors log files. For php and apache. You should find there more info about what is going wrong and why.


dajan
Beth  Klingner's profile picture
Posts: 10

18 July 2014, 2:08 AM

Thanks Dominque-Alain for your response. I should clarify that I'm using a test version of 1.9 at my institution - we're getting ready to upgrade from 1.7 to 1.9 next week and I'm not sure why when I try to upload a badge, it says my backpack doesn't have public collections when I have made a collection public in Backpack already.  I must be missing a key step.  I appreciate any suggestions you can offer. I have screen shots I can email to you but there isn't enough space to include them in this post. Here's the link to my backpack collection and I have made it public:

https://backpack.openbadges.org/share/69fd77a9b87bc4b2a83aedece06b0511/

Beth

 


 

Eric Rousselle's profile picture
Posts: 9

19 July 2014, 8:54 PM

Hi Beth,

There is a "bug" in the backpack, which make possible to display a collection badges even the collection is not set up as public. You should check that the check box for "public" in the collection box (before you open it in the main page), is checked.

I hope it will help.

 

Eric

Beth  Klingner's profile picture
Posts: 10

22 July 2014, 3:37 AM

Thanks Eric. I did make my collection public but it still doesn't work. We're upgrading to 1.9.1 tomorrow so I will try it again then and hope for the best. Just wondering if anyone else out there is using this plugin successfully? It would be great to see some Mahara pages with badges displayed. 

Beth

Don Presant's profile picture
Posts: 255

22 July 2014, 4:20 AM

Hi Beth:

I'm having no trouble displaying badge collections in Mahara 1.8.0...see examples below.

The only minor issue is that I don't see them in edit mode, just when I display the page.

 

http://www.savvyfolio.net/user/don/overview-open-badges

http://www.savvyfolio.net/user/don/my-open-badge-collection

HTH, Don

Kristina Hoeppner's profile picture
Posts: 3400

28 July 2014, 6:53 AM

Just a brief update: There seemed to have been a problem with the email address not being recognized in the profile. It worked for Beth on another instance of Mahara with the plugin installed.

Beth  Klingner's profile picture
Posts: 10

30 July 2014, 8:07 AM

Quick update - badges are now working for us - thanks to all for the help!  Now, I'm curious to see examples of how others are using and deploying badges through Mahara. 

 

Beth

Michael Wuttke's profile picture
Posts: 39

01 August 2014, 8:23 PM

Hello,

I don't know if I am right here with my questions. ;-)

But what are the changes of the the openbadgedisplayer plugin between version 1.0.1  and version 1.0.2? And is it necessary to update the plugin, because we are using mahara in version 1.8.x?

And is there an git repository of that plugin?

Thanks & Greetings,

Michael Wuttke

 

Kristina Hoeppner's profile picture
Posts: 3400

31 August 2014, 4:34 PM

Hello Michael,

Apparently, you are to use 1.0.2 with Mahara 1.9 as per https://mahara.org/user/ajk/open-badge-displayer

Please ask Eric or Antti if the code is on Github.

Cheers

Kristina