Forums | Mahara Community

Support /
Software requirements for different versions of Mahara


anonymous profile picture
Deleted user
Posts: 5

23 July 2013, 2:49 AM

Is there a document somewhere that specifies what versions of MySQL and PHP are needed for each major version of Mahara?  https://wiki.mahara.org/index.php/System_Administrator%27s_Guide/Requirements justs says MySQL 5.1 and PHP 5.3 - dos that apply to 1.4, 1.5, 1.6 and 1.7?

(Apologies if this is an FAQ - I searched the forums and docs, but couldn't find it)

Nick

Aaron Wells's profile picture
Posts: 896

23 July 2013, 2:45 PM

Hi Nick,

The system requirements listed there specifically apply to the most recent release of Mahara, which is currently 1.7. If you're doing a new installation of Mahara, you should use version 1.7. Those system requirements will probably be backwards-compatible with Mahara 1.5 and 1.6, but we don't actively test for that.

I don't think we have maintained a list of system requirements for past versions of Mahara. Probably the best you could do is look at the edit history for the system requirements page ( https://wiki.mahara.org/index.php?title=System_Administrator%27s_Guide/Requirements&action=history ) and correlate that with the release dates for past releases ( https://launchpad.net/mahara/+download ).

Cheers,

Aaron

2 results