Forums | Mahara Community

Support /
Display very slow


05 March 2012, 2:49 AM

My problem is the time to display pages Mahara

I displays after several minutes of use of displays very slow
Example for this address: http://eportfolio.ifeap.net/view/layout.php?id=454.

It is often when I work in data collection, pages ...

Do you have an idea about the origin of this dysfunction?

Some technical data

My setup:
shared Hosting
Database: postgres8

Contents of the file. htaccess
SetEnv PHP_VER 5
SetEnv REGISTER_GLOBALS 0
SetEnv MAGIC_QUOTES 0

05 March 2012, 3:42 AM

Could you please make your collection public so we could access it without login for which we have no credit.

Thanks

-dajan

05 March 2012, 8:11 AM

This is done
You can register on the platform
 

Thanks

Alain G


05 March 2012, 10:18 AM

Désolé Alain mais...

It still doesn't work. I have create an account on your server but I still can't acces your collection.

-dajan

05 March 2012, 10:29 AM

Ok,

I have browsed your Mahara site and I also have notice huge delays in displaying your pages. It is difficult to know what is happening because, for me, it is the first time I see this.

Did you ever try to have a look in the error log of your server (myslq and php) to know if something is going wrong here?

Do you have the same kid of symptoms with another web site installed on the same server (implying mysql and php)?

Did you try to install another copy of mahara to see if the behaviour is the same?

Sorry to not helping much here, yet

-dajan

11 March 2012, 4:23 PM

Thank you for your help.

The same problem is repeated on other shared hosting.

When a page does not display, I delete temporary files and I update the display, so it's good.

I have attached the link which gives the phpinfo: http://eportfolio.ifeap.net/phpinfo

Thanks

Alain

14 March 2012, 7:47 AM

Hello,

The solution given by the hosting OVH

Sessions are stored on the filerz, since the session for each image is checked, this causes errors.
It is advisable to store sessions in / tmp /
Here is the fix to put in the file auth / session.php

Today, the problem seems solved
It's very nice!
Can you tell me what you think of this change?

Alain

--------------------------------------------------------

//
// Set session settings
//
$path = "/tmp/";

//ini_set('session.save_path', '3;' . get_config('dataroot') . 'sessions');
ini_set('session.save_path', '3;' . $path . 'sessions');

//$sessionpath = get_config('dataroot') . 'sessions';
$sessionpath = $path . 'sessions';

Richard Mansfield's profile picture
Posts: 808

19 March 2012, 6:30 PM

There are other places in the code where strictly speaking, the path to the session directory ought to be changed as well.  A quick search shows these files:

htdocs/lib/upgrade.php
htdocs/lib/mahara.php
htdocs/auth/session.php
htdocs/auth/lib.php

But most of those occurrences are for the initial set up of the directories and cleaning up old files, so it might not matter in your case.

Kristina Hoeppner's profile picture
Posts: 3418

05 March 2012, 4:29 PM

Hello Alain,

I usually only experience a delay in the loading of a Mahara page if there are a lot of media artefacts like video, audio and large images on the page.

I haven't been able to check out your page yet as I cannot access it.

Cheers

Kristina

11 March 2012, 4:31 PM

Hello Kristina,

Thank you for your help

This is slow even for simple navigation mahara with empty pages.

You can register on the platform.

Alain

13 results