Forums | Mahara Community

Mahara/Moodle integration /
Mahara plugin stops save changes in grading feature of Moodle


anonymous profile picture
Account deleted
Posts: 1

20 September 2011, 22:23

Hi I have tried to find mention of this but can only find in a Moodle forum and they haven't found a solution.  We have Moodle 2.0.4 and when we activate our Mahara 1.4.0 then the "save changes" button in the assignment grading no longer sends anything to the server. If we disable Mahara it works fine.  This means I cannot go in and upload a marked assignment in the assignment module

Chris Kenniburg's profile picture
Posts: 34

21 September 2011, 6:48

I have the same issue.  What happens is the Export to Portfolio button appears in the grade assignment page.  When you have "Quick Grading" enabled where you can leave a comment and quickly grade from a drop down, teachers can no longer save their grades and comments.

Turning off the mahara Portfolio option solves the problem.  We can leave Mahara SSO enabled.  It is only with the portfolio enabled.

anonymous profile picture
Account deleted
Posts: 1

10 October 2011, 19:22

I've also got this issue.  I'm running Moodle 2.1  The frustrating thing is that although I can submit grades and feedback through quick grading, I cannot send a student a larger file, such as their submitted work with comments on.

I have communicated with Kristina about this, and she didn't seem aware of it.  However, she later decided it must be a Moodle issue, not a Mahara one.  I have spoken to other schools using both systems and they don't seem to have the problem, even though they are using the same Mahara/Moodle set up as me.  Making Mahara "Enabled, but Hidden" stopped the problem, but then of course I can't export anything to Mahara!  I can't leave it like that as then students won't be able to use it, and I can't keep swutching it on and off when a teacher wants to grade some work!

Rob

Kristina Hoeppner's profile picture
Posts: 4751

14 October 2011, 0:46

Hello Robin,

I could replicate your problem on one of our test servers. However, I encountered the same problem with the files download portfolio plugin enabled (and Mahara and all other portfolios disabled). Therefore, I still think that it is a Moodle problem. You are not even trying to connect to Mahara, but it is just the placement of the button (and the associated code).

Cheers

Kristina

4 results