Forums | Mahara Community

Support /
Can't add html to 'some html' block

Howard Miller's profile picture
Posts: 116

30 March 2010, 5:07 AM

I exported a forum discussion from Moodle 2.0dev to Mahara 1.2.3. This worked and the html file appeared in my Mahara files. 

 I then added a 'Some html' block to a view and the file picker displayed. The .html files where not visible in the picker. The directory structure was but not the files. Am I doing something stupid or is this a bug?? 

anonymous profile picture
Deleted user
Posts: 228

07 April 2010, 7:43 AM

Certainly sounds like a bug to me. Can you check the mimetype of the file in the artefact_file_files table?


BTW I added Leap2A support to Moodle - probably since you wrote that message.  That will certainly work better for exporting forums, but please test this problem further (and file a bug for me in the moodle tracker under portfolio API)

anonymous profile picture
Deleted user
Posts: 228

07 April 2010, 7:43 AM

Oh,  except for Leap2A you'll need the tip of Mahara master branch, 1.2.3 won't work :)

anonymous profile picture
Deleted user
Posts: 25

07 April 2010, 4:42 PM

The latest release (1.2.4) includes a database upgrade that tries to fix mimetypes that haven't been set properly. It may be worth upgrading and seeing if your problem persists.

anonymous profile picture
Deleted user
Posts: 47

16 July 2010, 12:20 AM

I've just tried this in a Moodle 2.0 Preview 4/Mahara 1.3 beta environment and the same thing is still happening - has anyone else tried this with the latest versions of both pieces of software?

anonymous profile picture
Deleted user
Posts: 11

09 December 2010, 4:48 PM

We're using Moodle 2 and Mahara 1.3, and the same thing is still happening. The mimetype isn't being set on sending an online text assignment as html from moodle, so the Some HTML block doesn't show anything in the file picker.

Leap2A works really nicely.

Kristina Hoeppner's profile picture
Posts: 3644

10 December 2010, 1:36 AM

Hello Gregor,

Thanks for testing. Of course it would be good for Mahara to recognize incorrectly or not set mimetypes. However, I think it would be good to fix that on the Moodle site (as well). Did you file a bug report there?



Ali Hastie's profile picture
Posts: 130

14 March 2011, 8:44 AM


I am using Moodle 2.0.2+ and Mahara 1.3.3. Is there any progress on this?



Mary Cooch's profile picture
Posts: 135

14 March 2011, 2:45 PM

I have just tried with Moodle 2.0.2 and Mahara 1.3.2 and I get the same as above - exports as html file fine but doesn't appear as available in the Some html block .

9 results