Forums | Mahara Community

Mahara/Moodle integration /
Tell us about your Mahoodle install


Julian Ridden's profile picture
Posts: 37

11 January 2009, 11:09 PM

Have you got mahoodle running? Why not share it with the community. Let us know how you are finding it and what you are using it for.

Julian 

Heinz Krettek's profile picture
Posts: 480

12 January 2009, 3:35 AM

Hi Julian,

i have installed several mahoodle combos. In most cases i used shared host.

Things drive me crazy at the moment as the sso crashed without any idea why? Together with Nigel we investigated, but could not find  the problem because the shared host does not allow further testing.

In the moment i use a vps host with moodle 2.0 beta  and my standard mahara on a shared host. Things are ok.

I will check Penny's new stuff for m2.0 this morning.

cheers Heinz

Brian Lockwood's profile picture
Posts: 19

04 February 2009, 1:03 PM

I just got Moodle integration working and I had some problems. I posted the solution in the support forum. We have a 2000 user Moodle which has been runnimng since Moodle 1.4, we are now 1.9.x.

I hope to use the eportfolios to allow students to present electrnically assessed work which they currently create web sites for. 

I hope that those students for whom web site design is not the purpose of the exercise, will be less distracted. 

Frank Ward's profile picture
Posts: 8

28 February 2009, 9:32 PM

My install was tough - just finished it but heartily rewarded. Errors kind of went like this -
- Dataroot
- Htaccess
- Weird lib error I accidentally discovered (quickly patched by Nigel who is now in my legend book)
- Realization it was postgres rather than mysql db needed
- Standard 'magic quotes error
- Final Victory

Have to say I was all ready to quit at the lib error. Went on You Tube to check out any mahara install vids when a certain Moodleman's video convinced me to go back and try again. Well done everyone. Now I'm off to Mahoodle!

Frank Ward's profile picture
Posts: 8

28 February 2009, 9:35 PM

I feel like such a fool! I've just re-read the title of the post. And there was me trying to impress Moodleman. It's 1.35am in the UK if that excuses me.
Nigel's profile picture
Posts: 1643

01 March 2009, 7:54 AM

Heh Cool I like Moodleman's videos too - I heard a rumour he was going to make another one, but I haven't seen anything yet - c'mon Julian! Wink

Let us know if your Mahoodle goes well, and remember that if you have a Moodle 2.0, you can test exporting content from it to Mahara as well.

Deleted user's profile picture
Posts: 7

12 March 2009, 8:07 AM

Hi!

 I'm trying to make work Moodle 1.9.2 and lastest Mahara without success. I work with lighttpd 1.4.13 and mysql 5. When i create the instituion and choose xmlrpc authentication, it cannot retrieve public key to finish creating it. I think moodle network works fine but i cannot finish the process with mahara. Moodle and mahara are placed in the same machine. I have a CAS server too and i will try to connect mahara with it too and without connecting it with moodle with moodle network.

Any idea? Thanks in advance!

Nigel's profile picture
Posts: 1643

12 March 2009, 4:50 PM

Hi - two things - firstly, have you read the Mahoodle documentation PDF? It's very helpful for setting up SSO, you might have missed a step. And secondly, we put some fixes into Moodle 1.9.3 that makes SSO more stable, so you might want to think about upgrading.
Deleted user's profile picture
Posts: 7

16 March 2009, 9:24 AM

Hi. Yes, i read the PDF. I've solved it. The problem was in the configuration of the net in the lighttpd chroot of my server, not in Mahara nor Moodle. Everything works fine now.

 The problem was that Mahara could not retrieve pem certificate. I thought it would be a good idea that a Mahara admin could introduce this value manually (as it can do in Moodle). What do you think?

 Thank you all!

Nigel's profile picture
Posts: 1643

16 March 2009, 6:33 PM

Yes, that would probably be a good idea, might be worth filing a feature request for it Smile
40 results