Forums | Mahara Community

Support /
System Requirements


Jackie Heenan's profile picture
Posts: 7

16 November 2023, 5:15

I have tried finding out myself the system requirements for Mahara 23.04

https://wiki.mahara.org/wiki/System_Administrator%27s_Guide/Requirements
Is only for 22.10

https://git.mahara.org/catalyst/mahara/
Here are the system requirements needed to run Mahara 23.04.

MySQL 8.0 or later
Mahara can be used with PHP version 7.4.X, 8.0.X, or 8.1.X

OR
https://git.mahara.org/mahara/mahara
Here are the system requirements needed to run Mahara 23.04.

MySQL 5.7 or later
Mahara can be used with PHP version 7.2.X, 7.3.X, or 7.4.X

I am assuming mahara/mahara needs an update, but I would like confirmation.
thanks
Jackie



Robert Lyon's profile picture
Posts: 748

16 November 2023, 10:09

Hi Jackie,

I've updated https://git.mahara.org/mahara/mahara to indicate the requirements for version 22.10 as that is where that repository got up to.

If you have access to https://git.mahara.org/catalyst/mahara/ and are using version 23.04 then you will need PHP 7.4 or later (preferably PHP 8.1)

Cheers

Robert

 

Jackie Heenan's profile picture
Posts: 7

16 November 2023, 21:38

Thanks Robert, that makes sense.

 

Jackie

3 results