Forums | Mahara Community

Support /
Tables in pages


Lisa Donaldson's profile picture
Posts: 33

28 August 2018, 10:04 PM

Hi all,

 

Seems a silly issue which has to have a quick resolution!

I have a student having an issue with tables in a page (I am having the same issue on investigation). We are running 17.10 and the student has inserted a table. She has gone into table properties and increased border size to 5 but borders are not appearing. On review of the source code, it looks fine to me - <table style="width: 613.333px; border-color: #808080; border-spacing: 1px; border: 3;"> but when page is saved and viewed no borders are displaying. When I go back in to look the border tag is missing again - <table style="width: 613.333px; border-color: #808080; border-spacing: 1px;">
<tbody>

Am I missing something? Thanks for any help!

Lisa

Cecilia Vela's profile picture
Posts: 69

29 August 2018, 9:16 AM

Hi Lisa,

I'm guessing the steps you follow are:

  • add a table to the tinyMCE editor (text area)
  • click on table properties
  • add "3" in the Border field

I had the same result as you when I followed those steps.

One thing you need to know is that the 'Border' field is quite small and is not really obvious but we can put more information in it not just a number. There we can define the border's width, style and color. So we could have for example "5px solid red"

I think your problem can be solved if you also add the border style in there.

In your case you can try either "3px solid #808080" or "3px solid"

border_style.png

Hope this helps,

Cecilia

Lisa Donaldson's profile picture
Posts: 33

29 August 2018, 9:34 PM

Thanks Cecilia - worked like a charm :)

 

Cheers,

 

Lisa

3 results