Forums | Mahara Community

Security Announcements /
Security issue relating to cross-site scripting <16.10.9; <17.04.7; <17.10.4


This topic is closed. Only moderators and the group administrators can post new replies.
Robert Lyon's profile picture
Posts: 418

06 April 2018, 11:32 AM

Avoid relying on TinyMCE code stripping alone

Vuln type: XSS
Impact: Code execution

Mahara 16.10 before 16.10.9, 17.04 before 17.04.7 and 17.10 before 17.10.4 are vulnerable to bad input when TinyMCE is bypassed by POST packages. Therefore, Mahara should not rely on TinyMCE's code stripping alone but also clean input on the server / PHP side as one can create own packets of POST data containing bad content with which to hit the server.

Reported by 陈瑞琦 (Chen Ruiqi)
Bug report: https://bugs.launchpad.net/mahara/+bug/1744789
CVE reference: CVE-2018-6182

1 result