Forums | Mahara Community

Support /
Failed upgrade from 16.10.1 to 17.04.2


na li's profile picture
Posts: 61

01 September 2017, 9:02 PM

Dear All,

I have searched in the Forum but didn't find similar posts, so I created this post and hopefully my problem can be solved soon.

Our current version of Mahara is 16.10.1, the following screenshot can show the details:

Screen Shot 2017-09-01 at 3.33.29 PM.png

I have cloned the production server and tried to upgrade from 16.10.1 to 17.04.2, but it failed.

Following is the upgrade steps, I've successfully upgraded Mahara every year by using the same steps:

  1. upload the tar.gz on to the server(/var/www/html)
  2. Go to mahara website and close the site (Administration->close site)
  3. Go to server and rename the original “mahara” folder to “mahara.old”
  4. open the terminal window and input command line: 
  • tar xvfz mahara-17.04.2.tar.gz
  • mv mahara-17.04.2/htdocs mahara
  • rm -rf mahara-17.04.2

  • nano /var/www/html/mahara/config-dist.php    (change the configure and rename the config-dist.php to config.php)

        5. set the file permissions:

  • cd /var/www/html
  • chmod -R 755 mahara
  • chmod 444 mahara/config.php
  • chown -R apache:apache mahara

       6. go to webpage to start database upgrade: https://[mahara website]/admin/upgrade.php?urlsecret=[the urlsecret in configure file]

But the upgrade was failed:

Screen Shot 2017-09-01 at 3.41.04 PM.png

I tried to run the command line to upgrade, but it still failed:

failed to upgrade20170901.png

Could anyone help with this? Big thanks in advance.

Best wishes,

Lina

na li's profile picture
Posts: 61

05 September 2017, 5:41 PM

I tried to upgrade from 16.10.1 to 16.10.4, but still failed with the same result: write failed: broken pipe.

 

Robert Lyon's profile picture
Posts: 360

11 September 2017, 10:50 AM

Hi Lina

The 'write failed: broken pipe' sound like an ssh type problem. I wonder if during upgrade you are dropping your connection to the database server? Is it on a different machine?

Cheers

Robert

3 results