Forums | Mahara Community

Mahara/Moodle integration /
SSO / Mnet Authentication issue


Robert Bellamy's profile picture
Posts: 6

09 August 2017, 3:44 AM

Hello,  

I am having a similar issue to others who have posted about SSO problems from Moodle to Mahara.  I imagine I am experiencing some kind of encryption issue, but I have checked the keys between Moodle and Mahara thoroughly.  In addition the XMLRPC entries under the Institution keep disabling themselves and I am unable to re-enable them.  I end up having to create new ones and then migrate the users over.  I have gathered all the relevant error logs, but I can't seem to scrub them clean enough to get past the new user link restriction.  Please let me know if you can help.

Thank you kindly,

Robert

 

Ubuntu / nginx

PHP 5.6.31

Moodle 3.0.9

Mahara 17.04.2

 

 

09 August 2017, 4:38 AM

I made a new MNET-connection between moodle and mahara and then I went to the user-administration. I searched vor all users in the institution and then I selected all users with the OLD autenticationmethod.

Then I choose "change authetication method" and select the new sso-connection. That worked for my mahara.

Can not reproduce it but think that the first connection is sometimes inactiv and can not be switched to active. Dont know why, but with the second connection there ist a workarround.

Robert Bellamy's profile picture
Posts: 6

10 August 2017, 2:19 AM

Thanks for the response Andreas,

 

I was able to create a new connection and got the users moved into it.  I still keeping hitting an error when trying to SSO as any user however.

 

The short version of the error goes like this:

 

PHP message: [WAR] a4 (api/xmlrpc/client.php:109) Undefined variable: payload
PHP message: Call stack (most recent first):
PHP message: * log_message(string(size 27), integer, true, true, string(size 47), integer) at /mnt/data/apps/10741/http/lib/errors.php:521
PHP message: * error(integer, string(size 27), string(size 47), integer, array(size 12)) at /mnt/data/apps/10741/http/api/xmlrpc/client.php:109
PHP message: * Client->send(string(size 25)) at /mnt/data/apps/10741/http/auth/xmlrpc/lib.php:103
PHP message: * AuthXmlrpc->request_user_authorise(string(size 40), string(size 25)) at /mnt/data/apps/10741/http/auth/xmlrpc/land.php:

Robert Lyon's profile picture
Posts: 343

10 August 2017, 8:50 AM

Hi Robert,

The payload problem error can be a couple of issues.

1) the payload is too big and so is dropped, see https://bugs.launchpad.net/mahara/+bug/1422837 for more info

2) the ssl certificate common name is too long, see https://reviews.mahara.org/#/c/7333/

Cheers

Robert L.

Robert Bellamy's profile picture
Posts: 6

11 August 2017, 9:05 AM

Thanks Robert,

 

I will try to apply those situations to my own and get back on with my findings.

 

^ _ ^

 

 

11 August 2017, 10:29 PM

Mahara login to Moodle and Moodle to Mahara doesn't seem to work. This is the error message I get 

Mahara: Invalid Parameter

A required parameter is missing or malformed

Missing parameter 'wr' and no default supplied

 

Any suggestions? 

 

Robert Bellamy's profile picture
Posts: 6

12 August 2017, 9:49 AM

Hello Dr. Nellie,

 

This thread appears to have been helpful to some others who experienced that issue:

https://moodle.org/mod/forum/discuss.php?d=89872

 

I hope this helps,

Robert B.

Robert Bellamy's profile picture
Posts: 6

23 August 2017, 2:22 AM

We were finally able to resolve this issue and I just wanted to share the relevant information.  Updating PHP to 5.6.31-4 corrected the problem we were seeing with the headers.  We were on 5.6.31 already but there was a very small update above that.  We are running on ubuntu16.04.1.  

8 results