Forums | Mahara Community

Support /
Access start date/time : problem

23 June 2017, 11:34 PM


We're testing the version 17.04 (theme modern) before installing it on our server but we have a huge problem with the acces start date/time (to limite the sharing of a page and to limit a projet in time, for example).

When I put in a date and I confirm, this is the result : 20/06/%A 00:00 and I can't change it nor save the modifications.

Here is the error message :
error message.png

Thanks in advance

Robert Lyon's profile picture
Posts: 445

24 June 2017, 8:04 AM

Hi Frederike,

Ok, there looks to be a couple of things going wrong here.

Firstly the date being formatted for the calendar widget is being formatted wrong - the '20/06/%A 00:00' should not contain '%A' - I suspect this is due to the
'pieform_calendar_dateformat' value in the language pack's langconfig.php file you are using is not of the right format.

It should be something like $string['pieform_calendar_dateformat'] = '%%Y/%%m/%%d';

If you are using 'English' the file can be found at: htdocs/lang/en.utf8/langconfig.php

If you are using another language then the file can be found in the dataroot of your site, eg for 'Deutsch' it would like at:


To see what valid options there are listed in:
htdocs/lib/pieforms/pieform/elements/calendar.php from line 201

The second issue it looks like you are having is you are trying to save an access rule that has no 'id' value

In htdocs/lib/form/elements/viewacl.php on line 62 there is a check to see if the saved access rule is one of the preset rules, eg 'public' where an 'id' is not needed otherwise it saves the access rule against some item, eg a group with group id, a user with user id etc

It sounds like you are trying to save an access rule that is neither one of the preset rules nor one that has an associated 'id'.

Can you let me know what rule you are trying to save is and what settings/values you have chosen?



Robert Lyon's profile picture
Posts: 445

24 June 2017, 8:11 AM

Hi again Frederike,

One more thought occurred to me - did you update you language packs when you updated your site?

There is a commandline tool to help you with that now.

On your server and in you site's 'admin' directory run the command

sudo php cli/sync_langpacks.php -h

This should give you the instructions on how to run the langpack updater to update langpacks of your choosing

You can also do this manually by downloading the langpacks you need from



3 results