Forums | Mahara Community

Support /
Local date in forums


Deleted user's profile picture
Posts: 15

15 June 2009, 3:31 AM

Hello,

We have a mahara installation with the spanish language installed, the problem is that when we post something in the forums the date is showed in English.

Should the date be changed in the forums using another langpack or would it remains the same using the parent language?

Many thanks.

Heinz Krettek's profile picture
Posts: 480

15 June 2009, 9:05 AM

Hi David,

 

try to add the following line into the longconfig.php file:

 

setlocale(LC_TIME,"de_DE.UTF-8");   ->> Wink

just right after the defined('INTERNAL') || die(); line.

cheers Heinz

15 June 2009, 10:07 AM

Thanks for the information, Heinz. David posted this question in the Spanish Community Forum, but I didn´t know how to change it.
Heinz Krettek's profile picture
Posts: 480

15 June 2009, 10:19 AM

Hi,

no problem, take care to insert correct Spanish "shortcuts"

Cheers Heinz

 

15 June 2009, 10:30 AM

I couldn't find the longconfig.php file. Do you mean  "langconfig file"  or it is the midnight sun we are experiencing now here that it is affecting my brain?
Heinz Krettek's profile picture
Posts: 480

15 June 2009, 11:50 AM

Hi,

langconfig.php in     /lang/es.utf8/

HTH Heinz

Iñaki Arenaza's profile picture
Posts: 253

15 June 2009, 12:51 PM

I know Windows isn't a supported platform, but just in case someone is using it, here's a "multi-platform"version of Heinz's trick :-):

 if (strtoupper(substr(PHP_OS, 0, 3)) === 'WIN') {
setlocale(LC_TIME, 'spanish');
} else {
setlocale(LC_TIME, 'es_ES.UTF-8');
}

Saludos.
Iñaki.

Deleted user's profile picture
Posts: 15

16 June 2009, 2:46 AM

I see the problem, is because windows doesn´t support UTF-8, so you need to define the locale manually. 

Many thanks to all of you!


 

8 results