Forums | Mahara Community

Mahara/Moodle integration /
networking problem


anonymous profile picture
Deleted user
Posts: 11

20 May 2009, 9:18 PM

hi
I want to integration mahara and moodle
so I have to use networking
I have already extension PHP openssl
and moodle already change the Networking value to 'On'
but mahara networking show
"Could not generate a new SSL key. Are you sure that both openssl and the PHP module for openssl are installed on this machine? "

I don't know why ?openssl are already installed
ps. I use xampp,windows

THANK YOU

anonymous profile picture
Deleted user
Posts: 1643

20 May 2009, 10:16 PM

Hi - on Windows, this is often caused because you have the openssl module installed, but it hasn't been configured properly. I believe this is done with an openssl.cnf file, but I don't know anything about where that file lives, or what its contents should be. Google may have more answers Wink
anonymous profile picture
Deleted user
Posts: 11

22 May 2009, 12:41 AM

I can't find any information about mahara ,openssl.cnf,windows
who can help me to solve this problem?

Iñaki Arenaza's profile picture
Posts: 253

26 May 2009, 4:11 AM

Have a look at this: http://www.php.net/manual/en/openssl.installation.php Wink

Saludos. Iñaki.

anonymous profile picture
Deleted user
Posts: 11

26 May 2009, 1:50 PM

I will try it, thank you
anonymous profile picture
Deleted user
Posts: 1

11 September 2009, 5:55 AM

I am using Mahara 1.1.5 on Windows XP and I'm using last (today's) Wamp .  I could follow installation instructions except for the necessary networking to moodle. Always getting the networking error:

Mahara: Site unavailable

The environment where Mahara is running is misconfigured and this is causing problems. You probably need to contact a server administrator to get this fixed. Details, if any, follow:

Could not generate a new SSL key. Are you sure that both openssl and the PHP module for openssl are installed on this machine?

 Instructions may be outdated

I've copied libeay32 and ssleay32 dll's to windows/system32 from wamp

I've generated the server.crt and sever.key and put in apache\Apache2.2.11\bin dir

I've modiefied the httpd-ssl.conf, php.ini(in apache's dir), 

In the days before I had stacked at the same point in my xampp installation for moodle
Too many days spent to get the networking running.

Apache Version : 2.2.11  
PHP Version : 5.3.0  
Loaded Extensions :
  • Core
  • bcmath
  • calendar
  • com_dotnet
  • ctype
  • date
  • ereg
  • filter
  • ftp
  • hash
  • iconv
  • json
  • mcrypt
  • mysqlnd
  • odbc
  • pcre
  • Reflection
  • session
  • SPL
  • standard
  • tokenizer
  • zip
  • zlib
  • libxml
  • dom
  • PDO
  • openssl
  • SimpleXML
  • wddx
  • xml
  • xmlreader
  • xmlwriter
  • apache2handler
  • curl
  • gd
  • mbstring
  • mysql
  • mysqli
  • Phar
  • pdo_mysql
  • pdo_sqlite
  • xmlrpc
  • mhash
MySQL Version : 5.1.36 
Thanks for anyones assistance!"
anonymous profile picture
Deleted user
Posts: 48

11 September 2009, 6:22 AM

check out the post here: http://mahara.org/interaction/forum/topic.php?id=1024
anonymous profile picture
Deleted user
Posts: 2

15 October 2009, 2:46 AM

Hi,

I also got the "Could not generate a new SSL key. Are you sure that both openssl and the PHP module for openssl are installed on this machine" on Windows, Apache, PHP, PostgreSQL...

Had Mahara at the root of the server, http://servername/, Mahara worked but got the above error.

When I moved it to own folder (and updated the config), it worked, http://servername/mahara/, now the networking page displays.

Tomorrow will try to link with Moodle, :) 

HTH
Trevor

 

anonymous profile picture
Deleted user
Posts: 4

25 March 2010, 12:43 PM

Hi all,

Ran into similar problems as stated above.
Any help or pointers are greatly appreciated.

===

System I work on is WindowsServer 2003 with Mahara (1.2.3) and Moodle(1.9.7 build 20100224) installed in a XMAPP (1.7.2 - full version) environment.
The Moodle and Mahara installs are located in the htdoc directory of the XAMPP setup.
Moodle and Mahara itself are up and running and function correctly (as far as I can see and familiar with).

In the Mahoodle setup I run into the same problem as mentioned here:

Could notgenerate a new SSL key. Are you sure that both openssl and the PHP module foropenssl are installed on this machine?”

Done sofar:

-         corrected/added environment variable configs on Windows Server 2003 for both PATH and PHPRC pointing to php and php.ini.

-         added config line on openssl.cnf location to Mahara config.php

-         copied libeay32.dll and ssleay32.dll to win\system32 directory

Questions remaining:

In the thread pointed by Iñaki (http://es.php.net/manual/en/openssl.installation.php) there is mention of ssleay.dll. Other solutions mention ssleay32.dll.

When searching local for ssleay.dll it proves to reside in  <d:\XAMPP\perl\site\lib\auto\Crypt\SSLeay\ >  in my case, as ssleay32.dll resides in many places.
Should I copy sslaey.dll to system32 dir?

In this thread (http://moodle.org/mod/forum/discuss.php?d=110343&parent=623908) there is mention of a php.ini file in the XAMPP/apache/bin directory.
In my default install (XAMPP 1.7.3) there is no such config file present.
Only places I have php.ini file is in

D:\Install\Development\PHP\php.ini
D:\XAMPP\php\php.ini

Therefore uncommenting extension=php_openssl.dll is not possible.
What to do?

Jaimo Alamo advised:

I've generated the server.crtand sever.key and put in apache\Apache2.2.11\bin dir

Is this really needed since I use a XAMPP setup?

I've modiefied thehttpd-ssl.conf, php.ini(in apache's dir),  

Not sure if this is still current.

 

Thanks in advance.
Regards, Jan 

 

anonymous profile picture
Deleted user
Posts: 4

20 April 2010, 6:14 AM

Getting the same error also with Mahara version 1.2.4 (2009111013).

Anybody?

21 results