Forums | Mahara Community

Developers /
Embedding SWF Files and IE

James Ballard's profile picture
Posts: 12

19 May 2009, 7:57 AM


 We've got an issue where SWF files embedded using the "Embedded Media" block do not display in Internet Explorer when upgraded to use Flash Player 10.

 See as an example

 The same SWF file is working outside of Mahara, and was working in Mahara before the Flah Player upgrade.

Unfortunately we aren't in position to to abandon IE as that is setup across the entire college network in this case.

Any ideas?



Nigel's profile picture
Posts: 1643

19 May 2009, 6:02 PM

A couple:

  1. Investigate the internalmedia blocktype, see if the embed code might need changing for flash 10 or something. Adobe or Google might have some clues.
  2. File a bug report with us (though it'll take a while for us to look at it)
James Ballard's profile picture
Posts: 12

31 May 2009, 9:44 AM

Thanks Nigel,

 Tried a few things and can't get this to work, including upgrading internalmedia block to use SWFObject 2 which worked with limited success.

On a standard web page SWFObject 1.5, 2.1 and 2.2 BETA work fine on all browsers in any mode.

When using them within Mahara the problem seems to be the $url object is not liked by Internet Explorer with Flash 10, although this works with earlier versions of Flash Player. 

 If you hard-code in a mymovie.swf link then it displays fine, however if you use the self::get_download_link system of Mahara then it doesn't display. 

 Likwise replacing a mymovie.swf URL with one from Mahara URL (http://localhost/mahara/artefact/file/download.php?file=10&view=5) into a standard web page using SWFObject will break the SWF from displaying in Internet Explorer.

Filed as bug:




3 results