Forums | Mahara Community

Support /
Language packs do not work

anonymous profile picture
Account deleted
Posts: 1

01 February 2013, 4:52


For our University of Applied Sciences I'm setting up Mahara besides Moodle.
I'm worried about the fact that language changes do not seem to work.
In maharadata/langpacks the subdirectories and subfiles are uploaded, visible/read-/writeable as specified and the structure is


and so on.

The language changing pulldown option appears, but changing it does not affect mahara.
Maybe I did not understand the installation instructions (which say nothing else but "Copy the obtained directory to the 'langpacks' directory inside your dataroot." in a proper way?

Where does my installation go wrong?



01 February 2013, 23:38

Hello Luca,

By the past, many of the langpacks problems have been resolved by checking the folder persmissions and ownsership. A chmod 777 and chown on the langpacks folder with the proper owner:group worked for me and for many times.

There is a known issue with the langpacks, when the lang files are stored within the artefacts, blocks, ... core files instead of lying in the langpacks. But it seems that in your case, you have put the lang files in the langpacks folder in your dataroot.

So, have a try with giving high permission (777) and checking the ownership of the folder and come back here to tell if the problem is solved or not.



2 results