Forums | Mahara Community

Support /
Windows Live Block


Rod Cullen's profile picture
Posts: 2

17 February 2012, 8:43 AM

Windows live provides the student email system at my university.  So I was really excited to discover the Windows LIve Block for Mahara.  We have a Moodle 1.9 and Mahara 1.4hosted service.  I asked our hosting service to install the Windows live block for Mahara which they have done but I now find I'm not able to get it to work.  Before going back to the tech support guys I thought I would just ask if anyone else has had similar probelms (I couldn't find anything specific on the forums but may have missed something) or if I'm just getting the process wrong.

For example, I've uploaded an Excel spreadsheet to my sky drive, shared it publicly and copied the following code into the Windows live block.

<iframe title ="Preview" scrolling="no" marginheight="0" marginwidth="0" frameborder="0" width="98px" height="120px" style="padding:0;background-color:#fcfcfc;" src="https://skydrive.live.com/embed?cid=046D1A1A6C22FA77&resid=46D1A1A6C22FA77%21138&authkey=ACqkux1oGGmzpuA"></iframe>

The block displays but is empty.  I've tried it with a folder, word doc, and some photos and get the same result.

  1. Is there a general problem with the block?
  2. Am I getting something wrong in the process?
  3. Should I just ask the tech team to reinstall the plugin?

Any advice appreciated.

Rod

Gregor Anželj's profile picture
Posts: 348

18 February 2012, 4:27 AM

Didn't have the time to exactly look throught the plugin soirce code, but as far as I remember I've programmed it it that way, that it only suports embedding the publically available docs, presentations, etc.

So you should paste the link to public resource!

HTH,
Gregor

Rod Cullen's profile picture
Posts: 2

20 February 2012, 3:54 AM

Hi Gregor,

Thanks for the quick response much appreciated as I realise how busy you must be.  The posting that I originally found by your good self says to use the embed code.

https://mahara.org/view/view.php?id=26018

I have also tried to use the public link (below) as you suggested but this doesn't work either.

https://skydrive.live.com/redir.aspx?cid=046d1a1a6c22fa77&resid=46D1A1A6C22FA77!138&parid=46D1A1A6C22FA77!133

Maybe it would be goo dto askl for the plugin to be reinstalled by our technical team.

Regards Rod

Gregor Anželj's profile picture
Posts: 348

20 February 2012, 9:20 AM

Will look into it, but I won't have the time till next week...

Gregor

A post by Deleted user was deleted

5 results