Forums | Mahara Community

Support /
connection to localhost reject on install

anonymous profile picture
Deleted user
Posts: 2

08 February 2012, 3:12 PM


Hello Mahara community,

I'm trying to install Mahara on a Windows 7 64 bit laptop.

I'm using WAMP 2.2.

I've followed the instructions given here:

and filled in the values for the config.php file in the C:\wamp\www\mahara\ directory like so

which I'm 95% sure are right.

$cfg->dbtype   = 'mysql5';
$cfg->dbhost   = 'localhost';
$cfg->dbport   = null; // 80 or null
$cfg->dbname   = 'mahara';
$cfg->dbuser   = 'root';
$cfg->dbpass   = ''; 
$cfg->wwwroot = 'https://localhost/mahara/';
$cfg->dataroot = 'C:\\wamp\\data'; 

But after I go to:

and click on mahara under Your Projects to install, Chrome informs me that:
"(the) connection attempt to localhost was rejected. The website may be down, or your network may not be properly configured."

I'm pretty sure that it's making the connection to the mahara database because if I change

dbuser in the config file to 'Ross', I'll get the following:

"Mahara could not connect to the application database.

* If you are using Mahara, please wait a minute and try again
* If you are the administrator, please check your database settings and make sure your database is available

The error received was:
mysql error: [1044: Access denied for user ''@'localhost' to database 'mahara'] in CONNECT(localhost, 'Ross', '****', mahara) "

I've also looked through the README post in the support forum for my problem but nothing seems to fit.

(probably because the problem is really simple, but then again, I'm new at setting up this kind of thing)

Could someone help me figure out what is going wrong?

anonymous profile picture
Deleted user
Posts: 197

08 February 2012, 4:36 PM

Hi Ross,

Can you try changing the $cfg->wwwroot setting from 'https://localhost/mahara/' to be  'http://localhost/mahara/' (note the change from https to http).

What is likely happening is that mahara is loading merrily and then redirecting to https://localhost/mahara/ because that's what the configuration tells it to do. And you possibly don't have the SSL set up to accomodate this.

Hope this helps!


anonymous profile picture
Deleted user
Posts: 2

08 February 2012, 9:16 PM

Thank you very much, Melissa.

That did it.

I knew it would be something simple like that that I was overlooking.

3 results