Forums | Mahara Community

Mahara/Moodle integration /
Got my first Mahoodle working... going to the beach helped

anonymous profile picture
Account deleted
Posts: 47

21 March 2009, 20:50

Hi. Well, after literally weeks of preparation for the big moment of activating the SSO between my Mahara siet and my Moodle site, it is working.  Of course, there had to be a glitch, that sent a shiver through me after getting everything ready.  I was worried I was having hosting-related issues.

First, to get the XMLRPC needed for the SSO to work, I needed to change servers at my hosting service. They are great there at BTW.  Before I ever installed Mahara I ran the requirements list past them and they told me everything woudl be OK on one of the newer servers.  So after getting all that going, a fresh install of Mahara and moving all my Moodle stuff over I was feeling really good.

I read that Mahoodle PDF through a dozen times, and of course I needed/wanted to do the least common SSO - from my Mahara to my Moodle site.  That is because I really like working with Mahara's community features for my application, and "just" using Moodle as my classrooms (you don't even want to know the stuff I had previously modified in Moodle to "try" to build community features Cry )

Anyway, started late last night to do the config stuff. Of course, I started with Mahara, which went so smoothly it wasn't even funny.  But Moodle! I coudl not get the key to appear in that text box. I was so tired, I made myself stop before I screwed up anything. Then this morning (Saturday), I tried it all again - still could not get it working on Moodle side. So I decided to take the family to the beach all day.

When I got back this afternoon, I tried again, this time looking carefully at the error on that Moodle page - aha! It said the key did not match the host name, which when I looked it was reading a subdomain I had used weeks ago when just doing test installs!  I had done one upgrade to 1.1.2 and I guess the original key was encrypted with the original install subdomain.

Well, being all rested made the difference - I did 5 minutes of searching the Mahara site and found a Nigel reply to someone detailing the steps to deleting the key related stuff in the host tabel and the config table. Did that.  Tried it again - it all works!!!!!

So far testing a few users logging in to my Mahara and SSO across to the Moodle site works, including enrolling in a class AOK.

I guess I have two "questions" :

1. Are there any other tables I should look through that might have vestiges of the orginal subdomain?  I can see that as a potential problem.  Maybe someone could give me the SQL I need to search for a fragmant of text, through all the tables? My attempts to do that search have not been good so far.

2. Can we add some debugging steps to the Mahoodle PDF, or consolidate the forum posts into a FAQ (or FAProblems)?   That could be useful for newbies.

Thanks to all the people who have worked on this Mahoodle integration - it really adds a bunch to both packages. Very very very smart approach Smile



anonymous profile picture
Account deleted
Posts: 1643

22 March 2009, 18:13

Hi - glad you got it working ok Cool

The Mahoodle PDF is quite old now - although the advice in it is still excellent. You can see it's older as it still shows the Mahara 0.9 theme. I've been meaning to move its contents to our wiki, but there are many other things to do...

The wwwroot moving problem is a bit of an annoyance. SSL keys are generated for wwwroots (they have to be), but there's no code on either side checking to see if the wwwroot has changed, and it appears this happens quite a lot. It would be nice for us to one day add some feature that checks this.

Currently the future of MNET is a little clouded, with Moodle going to a new web services API for Moodle 2.0. The protocol and the UI for configuring it might change quite a bit between now and then. We will have to see how it changes over the next year or two.

anonymous profile picture
Account deleted
Posts: 91

27 March 2009, 10:09

Glad you got it working.

The integration has worked well for us, the only issue being that accounts get duplicated if users first login with LDAP (as opposed to coming from Moodle).... I guess you dont have that issue.

I will be setting up Moodle Alpha with Mahara soon to see what other goodies are in store for us later this year Cool

3 results