Forums | Mahara Community

Support /
Error wall posting

anonymous profile picture
Account deleted
Posts: 5

15 October 2011, 13:44


I just went live with mahara in our school and I have to say the pupils love it. One problem however. when posting on anyone's wall i get the following message:

ERROR - something bad happened after headers have been sent. Check the error log for more information

I am with hostmonster, I have a mahoodle site and I think it may have to do with some kind of configuration setting or permissions on the server. I had to install mahoodle manually as hostmonster do not have a script. Any ideas on this issue would be welcome.

PS the item does actually post on the wall but this annoying error message appears after posting.

François Marier's profile picture
Posts: 411

16 October 2011, 20:33

Hi Michael,

you'll have to take a look at your web server's error log to know what the problem is.



anonymous profile picture
Account deleted
Posts: 2

09 November 2011, 15:34

I've had the same error message.  I am just getting the hang of editing views so I'm coming from a pretty basic level.  Can you explain the error log please, and identify where this is and who has access to it.   Much appreciated.

Mary Cooch's profile picture
Posts: 135

09 November 2011, 16:07

Actually - Adam sent me a view tonight  from this Mahara here and it had the same error message!

anonymous profile picture
Account deleted
Posts: 808

09 November 2011, 19:33

Mary, I've seen that on too, in the sideblock on views where someone has changed the theme.  It's due to a customisation on this site that tries to put a navigation block from the custom theme on all views.   It shouldn't happen on a normal Mahara.

anonymous profile picture
Account deleted
Posts: 5

12 November 2011, 15:28

I checked the error log and this is what i have.

[WAR] 0b (lib/web.php:2214) Headers already sent when redirect() was called (output started in /home1/uddingst/public_html/uddingstongrammar/mahara/artefact/cpds/lang/en.utf8/artefact.cpds.php on line 83
[12-Nov-2011 14:21:01] Call stack (most recent first):
[12-Nov-2011 14:21:01]   * redirect() at /home1/uddingst/public_html/uddingstongrammar/mahara/blocktype/wall/lib.php:202
[12-Nov-2011 14:21:01]   * PluginBlocktypeWall::wallpost_submit("/user/view.php?id=5") at /home1/uddingst/public_html/uddingstongrammar/mahara/lib/pieforms/pieform.php:512
[12-Nov-2011 14:21:01]   * Pieform->__construct(object(Pieform), array(size 7)) at /home1/uddingst/public_html/uddingstongrammar/mahara/lib/pieforms/pieform.php:161
[12-Nov-2011 14:21:01]   * Pieform::process(array(size 2), array(size 2)) at /home1/uddingst/public_html/uddingstongrammar/mahara/lib/pieforms/pieform.php:71
[12-Nov-2011 14:21:01]   * pieform() at /home1/uddingst/public_html/uddingstongrammar/mahara/blocktype/wall/lib.php:177
[12-Nov-2011 14:21:01]   * PluginBlocktypeWall::wallpost_form(array(size 8)) at /home1/uddingst/public_html/uddingstongrammar/mahara/blocktype/wall/lib.php:72
[12-Nov-2011 14:21:01]   * PluginBlocktypeWall::render_instance(array(size 8)) at /home1/uddingst/public_html/uddingstongrammar/mahara/lib/mahara.php:1162
[12-Nov-2011 14:21:01]   * call_static_method() at /home1/uddingst/public_html/uddingstongrammar/mahara/blocktype/lib.php:627
[12-Nov-2011 14:21:01]   * BlockInstance->render_viewing(array(size 8)) at /home1/uddingst/public_html/uddingstongrammar/mahara/lib/view.php:1184
[12-Nov-2011 14:21:01]   * View->build_column(object(BlockInstance)) at /home1/uddingst/public_html/uddingstongrammar/mahara/lib/view.php:1152
[12-Nov-2011 14:21:01]   * View->build_columns(object(BlockInstance)) at /home1/uddingst/public_html/uddingstongrammar/mahara/user/view.php:307

any ideas?
anonymous profile picture
Account deleted
Posts: 808

13 November 2011, 15:25

Michael, check that plugin referred to in the first line - specifically, does the file artefact/cpds/lang/en.utf8/artefact.cpds.php (line 83) have any blank lines or spaces at the end (after a "?>")?  If so, you can hopefully fix it by removing the "?>" at the end of the file.  If it's occurring in the most recent version of the plugin, you should tell the plugin maintainer.

7 results