Forums | Mahara Community

Developers /
Remove the "Wall"


anonymous profile picture
Deleted user
Posts: 4

17 March 2009, 10:55 PM

Hi,

Just wondering what would be involved with removin or preferably disabling the "Wall" Plugin/Feature completely? Thanks.

anonymous profile picture
Deleted user
Posts: 1643

18 March 2009, 6:19 PM

Hi - we haven't made a UI for disabling plugins yet, though it's been something we've been meaning to do for quite a while.

Try looking in the blocktype_installed table, and setting the 'active' flag for the wall to 0 - does that disable it?

If not, your best bet might be to remove all wall related rows from the database completely, then remove the code.

anonymous profile picture
Deleted user
Posts: 4

18 March 2009, 7:46 PM

Unfortunately this does not appear to help, digging into the functions i believe you need to adjust the query used in "get_blocktypes_for_category".

FROM: WHERE btic.category = ?
TO:  WHERE btic.category = ? AND bti.active=1

 This seems to have resolved the issue.

 

anonymous profile picture
Deleted user
Posts: 4

18 March 2009, 8:41 PM

Would this be applied to new user profiles as well? I noticed the wall is added by default to new accounts profiles.
anonymous profile picture
Deleted user
Posts: 1643

18 March 2009, 8:57 PM

Hi - there's probably a lot of places where we need to check that active flag. Although we made the flag, we haven't been very careful in checking it, as there was no UI for disabling plugins (and thus no bug reports it wasn't working... Wink).

If you find some more places where the flag needs checking and are able to submit a patch, please do! Smile

anonymous profile picture
Deleted user
Posts: 5

08 July 2010, 3:39 AM

I got around this one with a quick bit of css, just add

.bt-wall {
    display:none;
}

to views.css in your theme. I also emptied the table blocktype_wall_post from the database (after exporting it for safe keeping)

I know the code will still be rendered and they will still see it when they edit their profile but the wall is *effectively* disabled.

anonymous profile picture
Deleted user
Posts: 5

08 July 2010, 3:44 AM

Oh, just realise that you just have to go to Site administration > Administer Extensions and click [Disable] next to wall. This must obviously be an old topic.

7 results