Forums | Mahara Community

Mahara/Moodle integration /
Moodle 2.0.3 and Mahara 1.4 MNet Problem

anonymous profile picture
Account deleted
Posts: 2

25 July 2011, 7:05

I have cross-posted this in the mnet forum at

I have Moodle 2.0.3 and Mahara 1.4 both installed on the same Ubuntu 10.04 server in different directories inside the web root of the apache www directory.  Both of them work independently. I have been using and administrating this moodle instance on 1.9 and 2.0 for a couple years now.  The Mahara install is new and only has one user (the admin).

Their web addressess are:

I followed the steps in the New Mahoodle install document.  Thanks, by the way. That was very nicely done.

It appears that I can connect to the moodle via networking in Mahara (it recognizes the key).

However, in Moodle, when I walk through the mahoodle setup steps I get to the point where I setup the peer under networking.  I put in the proper www root for the mahara instance (with a trailing / like this: ).  I tried it the other way without the / and got the same results.

It seems to pull up the proper key for the mahara instance but below it gives me this message: "The public key you are holding for this host is different from the public key it is currently publishing. The currently published key is:"

Then there is no key at all listed.  Any ideas?  I don't see anything like this in the forums.  I know this is probably unusual to network two instances on the same server (same IP address and everything) but it seems to make sense in this setting, as the server has enough resources to run them both.

I have two further clues that may help someone give me a clue in the right direction. 

  • The mahara instance does now appear in my list of peers in :

site admin>Networking>Manage Peers (It still says the public key isn't the same but the current key space is blank)

  • I have a network servers block on my page with a link to the mahara site.  When I click on it I get a server message from apache that says:

Not found
The requested URL /mahara/auth/mnet/land.php was not found on this server.

It seems to be sending it to a page in mahara called mnet (no such page).  It seems to be offering a token in the url.  I don't even have a /mahara/auth/mnet directory but I do have a /mahara/auth/xmlrpc directory in my mahara subdirectory.

I appreciate any help you can provide me.



anonymous profile picture
Account deleted
Posts: 2

25 July 2011, 12:27

I found that if I changed the mnet in the url to xmlrpc that I could get from moodle to mahara and it would authenticate. 

The orginal url that my moodle server block produced was: and then a bunch of token stuff

So, I just copied and pasted the directory and contents /mahara/auth/xmlrpc to /mahara/auth/mnet and voila, it worked.  So, I think this workaround made the moodle block point to a place that existed.  This isn't ideal but it works.

It doesn't explain the part about the published key that doesn't show up.

2 results