Forums | Mahara Community

Support /
Problem with artefact file type


Nathan Friend's profile picture
Posts: 12

08 July 2011, 2:43 AM

Hello,

When users upload Flash video files (.flv) they can't add them as embeded media.  I did a bit of snooping around and found that in the Mahara database table artefact_file_files the flash vieos had the file type field set as application/octet-stream, if I change this to video/x-flv the video embeds OK.

Any idea how I can ensure these files are categoriesed in the database correctly?

Cheers,

 

Nathan.

anonymous profile picture
Deleted user
Posts: 21

08 July 2011, 10:08 AM

What version of Mahara are you using?
I thought this had been fixed at some point in 1.3.*, the problem went away for us anyway.

It appers to be down to the users PC not sending the correct MIME type at the time the file is uploaded. How you fix that is browser and OS dependant, it's either registry or browser config settings. The simple workaround I used for a few people was to install vlc player (videolan.org), it sets the correct MIME types just as a side effect.

Nathan Friend's profile picture
Posts: 12

11 July 2011, 3:36 AM

Hi Gary,

We're are runing 1.3.3.  We have VLC installed.  Do you have instructions on how to setup the mime type for IE and Firefox on Windows and Mac?

 

Cheers,

 

Nathan.

François Marier's profile picture
Posts: 411

12 July 2011, 4:30 AM

Hi Nathan,

I have been able to reproduce the problem and have filed a bug report for it:

  https://bugs.launchpad.net/mahara/+bug/809216

Cheers,

Francois

Nathan Friend's profile picture
Posts: 12

12 July 2011, 6:08 AM

Thank you Francois, Mahara has a great community.

5 results