Forums | Mahara Community

Support /
HTMLPurifier Error


29 March 2011, 8:04 PM

On attempting an installation (1.3.x), installation process seems to work fine. On attempting to display views I get a black page.

Apache Error log shows the following:

Class 'HTMLPurifier_AttrDef_HTML_Bool' not found in /srv/www/htdocs/dev/mahara/lib/htmlpurifier/HTMLPurifier/AttrTypes.php on line 20

Any ideas? Thanks in advance.

François Marier's profile picture
Posts: 411

29 March 2011, 10:02 PM

Hi Craig,

What exact version of Mahara are you running? We've just upgraded HTML Purifier in 1.3.5 so you might want to try that.

Cheers,

Francois

29 March 2011, 11:35 PM

Same error occurs on all attempted installations of mahara ( including 1.3.5 ). I assume the error is due to some configuration issue either within my server of the mahara setup, but I'm at a loss to know where to start looking.

François Marier's profile picture
Posts: 411

30 March 2011, 12:49 AM

What version of PHP are you running?

30 March 2011, 1:48 AM

PHP 5.2.14

François Marier's profile picture
Posts: 411

03 April 2011, 9:57 PM

Weird, it works fine on my PHP 5.3.2.

The line causing problems is this one:

  $this->info['Bool']    = new HTMLPurifier_AttrDef_HTML_Bool();


and that class is defined in this file:

  htdocs/lib/htmlpurifier/HTMLPurifier/AttrDef/HTML/Bool.php


which is included from either of these:

  htdocs/lib/htmlpurifier/HTMLPurifier.includes.php

  htdocs/lib/htmlpurifier/HTMLPurifier.safe-includes.php

 

Can you make sure that all of these PHP files exist and are readable by the webserver user?

Other than that, you could try a different version of PHP to see if it has anything to do with that.

Cheers,

Francois

6 results