Forums | Mahara Community

Support /
Installation Help


Marcio Gandra's profile picture
Posts: 4

28 March 2011, 2:18 PM

 I´ll post here some screen shots of all my configuration because i´ve tried everything told in this forum but the error persist. ( Internal Server Error )

 www.h2art.com.br/screenshotmahara.htm

Mahara Version 1.3.4 Stable

Installation folder:
"home/mineral/public_html/marn" ( marn is a abreviation of Mining Accident Report Network  , i used it instead of "mahara" name. )

Data root:
Permissions: 777
"home/mineral/data" ( 2 levels behind mahara installation folder )

Config.php:
$cfg = new StdClass;
$cfg->dbtype   = 'postgres8';
$cfg->dbhost   = 'localhost';
$cfg->dbport   = null;
$cfg->dbname   = 'portaldamineracao';
$cfg->dbuser   = 'admin';
$cfg->dbpass   = 'xxxxxxxxx';

$cfg->dbprefix = 'mineral';
$cfg->wwwroot = 'http://www.domain.com.br/marn';
$cfg->dataroot = '/home/mineral/data';
$cfg->emailcontact = 'email@email.com.br';

Htacess:
( removed all php flags )


<Files config.php>
    Order deny,allow
    deny from all
</Files>
<Files .htaccess>
    Order deny,allow
    deny from all
</Files>
<Files lib.php>
    Order deny,allow
    deny from all
</Files>

<IfModule mod_headers.c>
    Header unset ETag
</IfModule>
FileETag None

My host:
Shared hosting but with all the necessary resources to run.

m hanrahan's profile picture
Posts: 1

28 March 2011, 7:46 PM

If you've preserved the default directory structure of mahara you might try

$cfg->wwwroot = 'http://www.domain.com.br/marn/htdocs';

instead of what you have: $cfg->wwwroot = 'http://www.domain.com.br/marn';

also, your screenshot indicates that your wwwroot and httpswwwroot have different values.  if you're not using https than comment that out and provide the correct url (with htdocs) to the wwwroot (or vice versa).

Marcio Gandra's profile picture
Posts: 4

28 March 2011, 8:45 PM

Thank you, but i´m using the new version of mahara and there´s no htdocs folder inside main folder.

 

The mahara application will run in www.domainname.com.br/marn ( inside marn there is all install files)

And in the server mahara  folder is located in "home/mineral/public_html/marn" ( marn is the name i used instead of mahara ).

 

Marcio Gandra's profile picture
Posts: 4

28 March 2011, 11:43 PM

 found the error!

 

root web adress in config.php must end with " / "

4 results