Forums | Mahara Community

Support /
Install hung on "Performing installation...

anonymous profile picture
Deleted user
Posts: 2

22 March 2011, 6:56 AM


I'm new to Mahara (but not to CMS' and LMS') and this is my first attempt to install. I've read all the relevant documentation and forum posts I could find and there doesn't appear to be a satisfactory solution to this problem, so perhaps someone could resolve it here.

OS: Windows Vista

Server: Wamp (Apache 2.2.11 , MySQL 5.1.36, PHP 5.2.11)

Mahara version: 1.3

On the page localhost/mahara/admin/upgrade php I get: "Performing installation..." the same as this post here:

I'm fairly proficient with PHP, databases, etc. and any help you can offer will be most appreciated and probably useful to anyone else who wants to test Mahara locally before a public install.

I look forward to reading your replies.

All the best,

Matt Bury

Wullie's profile picture
Posts: 252

30 March 2011, 3:14 AM


Did you have a look here?

Pay special attention to Q/A 3, Step 1 - I also found that ensuring that the extension=php_fileinfo.dll is commented out helped too.

Hope this helps

anonymous profile picture
Deleted user
Posts: 2

30 March 2011, 6:17 AM

Hi Wullie,

Thanks for the help.

I followed the instructions exactly as described by the link you posted but I still get th same result. I'm using Wamp 2.0. Also I couldn't find "extension=php_fileinfo.dll" anywhere in the php.ini file.

Thanks in advance.


Wullie's profile picture
Posts: 252

30 March 2011, 6:22 AM


I must admit, I tried installing yesterday and it hung for ages, came in first thing this morning and it worked - after I'd deleted all the old folders in my mahara folder first, then recreated the database.

Not sure if it makes a difference or not, but I'm using XAMPP rather than WAMP.

4 results