Forums | Mahara Community

News /
Mahara 1.1.1 Released

This topic is closed. Only moderators and the group administrators can post new replies.
Richard Mansfield's profile picture
Posts: 808

26 February 2009, 11:11 PM

This release includes an upgrade path from 1.0. If you wish to upgrade, we encourage you to make a copy of your 0.9 website and test the upgrade on it first, to minimise the effect of any potential unforseen problems.

You can read the release notes, or get downloading (.tar.gz, .tar.bz2, .zip). Enjoy!

This release fixes two problems with the upgrade from 1.0.x for MySQL (mentioned here and here).

William's profile picture
Posts: 10

27 February 2009, 12:07 AM


Sorry, still no luck.
Is it because my Mahara is dead already in the v1.1 discussion?
But thank you for your effort
Error as: 



Could not execute command: ALTER TABLE "ma_group" ADD grouptype CHARACTER VARYING(20)

Call stack (most recent first):
  • execute_sql("ALTER TABLE {group} ADD grouptype CHARACTER VARYIN...") at /web/
  • xmldb_core_upgrade("2008040218") at /web/
  • upgrade_core(object(stdClass)) at /web/

27 February 2009, 10:43 PM

I may suggest to login mysql, select the mahara db with

use maharadb;

and perform an upgrade.
Again set it to 1 when luckily if you're done :) 
Nigel's profile picture
Posts: 1643

28 February 2009, 2:54 AM

Hi William - yes, probably. Do you want me to try and work out how to "downgrade" your database to 1.0.9 so you can have another go? If so, I will need a copy of your database.

William's profile picture
Posts: 10

28 February 2009, 5:14 AM

 Dear Nigel,

 That will be great!

Please find my file at:


Edits to this post:
Nigel's profile picture
Posts: 1643

01 March 2009, 7:08 PM

Thanks William. I have downloaded the file, I will try look at this as soon as I can.
William's profile picture
Posts: 10

01 March 2009, 8:08 PM

Dear Nigel,

Would you please delete the link for security?




Nigel's profile picture
Posts: 1643

01 March 2009, 9:00 PM

I did so, though you should remove the file from your server too.

28 February 2009, 10:14 AM


I installed mahara 1.1.1 on intranet environment. (win xp sp2, apache 2.2.11, mysql 5.1.30 and php 5.2.8). Installation process was easy and I got mahara installed. I tried some features and so far so good, I like it. But one feature is missing, user can not upload file(s). When we click upload file button it keeps processing all the time. My web server root (localhost) is c:\webserver. In config.php my $cfg->dataroot is ‘c:\webserver\maharadata’, $cfg->wwwroot = ‘http://localhost/mahara/’. Did I miss something? Another thing is that when I click logout button, the site goes to (?)

Darko Grabar's profile picture
Posts: 18

17 March 2009, 9:28 AM


I have upgrade mahara from 1.06 to 1.1.1 and I was having same problem with file upload.
First error was because we didn’t have php_exif extension which is required by lib/file.php (func. is_image_file, line 360). After that file upload was working under My files but not if attaching file to blog post.

After looking in our Apache error log we have found that we were missing mahartefact_blog_blogpost_file_pending table. So I have created new clean mahara 1.1.1. install and copied the structure of the table in to active database and now everything is working.

Question: Is this upgrade error? That is why upgrade process didn’t create that new table. And what is this table used for? 

10 results