Forums | Mahara Community

Support /
View - Place Feedback and Attached Files

Mary McKee's profile picture
Posts: 5

15 October 2010, 14:29

Recently, a faculty member of ours had students create views.  Within that view, the student would use the Place Feedback feature in his/her own portfolio and attach a file.  When others with access to that particular view attempt to click the attachment, they are denied access.  they can open the View, but the attached file in the feedback is blocked.

I've looked, and the file does exist in the user's Files area.  A folder entitled, commentfiles is generated, and the file resides there, but only the view's author is able to click the attachment to open it.

Access is denied even if the student checked the "Public" option when placing the feedback.

Is there a toggle in the settings where attachements can in Feedback can be blocked.  I realize there are other ways for students to post files in views, but unfortunately, this is how the instructor asked students to share files in their small groups.

Thanks for any leads you can provide.

Mary Beth

anonymous profile picture
Account deleted
Posts: 808

19 October 2010, 16:44

Mary Beth,

Yep, it's a problem and I've created a bug for it:

I think we really need to just sort out the permissions problem.

I thought a good short term fix might be to hide the "Attach File" selector when "Make public" is checked, but that won't work for feedback that's initially posted as private and then later made public.

Unfortunately there's no setting to turn attachments off.  But if you urgently need to remove the attachment option from all the feedback forms, it is relatively easy to do if you are willing to edit the code.  Just find the following lines in the file artefact/comment/lib.php and delete them from the file:


        if ($USER->is_logged_in()) {
            $form['elements']['attachments'] = array(
                'type'         => 'files',
                'title'        => get_string('attachfile', 'artefact.comment'),
                'defaultvalue' => array(),
                'maxfilesize'  => get_max_upload_size(false),

2 results