Forums | Mahara Community

Support /
big fat anomaly


anonymous profile picture
Deleted user
Posts: 7

20 September 2010, 3:07 PM

I installed Mahara on a windows based server.  After a few configuration problems, worked like magic! the only problem i had, was i had to keep loging in all the time.  everytime i wanted to change some things in the admin side, it kept asking me to log in.  I looked at all the support from this group, and found the problem was with the write permissions yada yada yada.

 

i called my hosting people and they said i could only change write permissions if i was working with files on the unix package.

I change the package to unix.  now the damn thing doesn't work again !!!  I changed all the write permissions, checked everything in the config and i am really at a loss!! it kept coming up with a 500 error saying that the file wasn't there.

i'm no techy, and have been trying to install mahara for a week now.  and i was almost crying when i was able to install it this morning and log in as an admin and play with it !!! now i got nothing again lol

any tips or tricks ??

anonymous profile picture
Deleted user
Posts: 8

21 September 2010, 6:12 AM

Hi,

If the server says file not found - it usually means that the file isnt there or cant be read. Im not too sure, but I recall reading somewhere that mahara (or was it moodle) works best under *nix instead of windows.

 

To resolve this I would recommend, that on a windows server, you use the windows package - secondly you can change the permission of folders and files in windows (just not as much fine grained control as *nix). If you have sftp access to the server  you can usually browser the files by making a network connection from 'my computer',  right click on indivdual files and folders to set the permissions.

 

Another approach that may work is if you do a test install on your own computer first, set the permissions properly, then copy the files to the server. From experience I find that in some cases the file permissions are left intact. But its really a hit and a miss, depending on the operating system your using and the programs your using. Maybe someone can shed some light on this issue.

 

Husman

anonymous profile picture
Deleted user
Posts: 214

21 September 2010, 8:47 AM

Hi again Sally,

The 500 error message usually relates to the contents of the .htaccess file.

An .htaccess file on a web server allows some control over the web server - you can potentially change various settings like php settings, or the default index file (e.g. if you go to /, your web server sends you to /index.php, and failing that /index.html) and other related things.

Mahara ships with an .htaccess file in an attempt to ensure certain settings are enabled or disabled and thus improve base security. Unfortunately on many shared hosting systems, the control of many of the settings we attempt to change is limited.

You can found out which is the offending line by having a look at the apache error logs if you have access to these - it will usually be fairly obvious from the error message I think.

If you don't have access to these, I'd suggest remove the contents of the file, and adding parts back until you get the 500.

On a *nix server, files which start with a . are hidden so you may have to enable a setting on your ftp client in order to see them.

Hope that this helps,

Andrew

anonymous profile picture
Deleted user
Posts: 7

21 September 2010, 5:06 PM

Hiya Andrew

 

thanks for your reply. i still aint getting it! I'm sure it's something so simple, and once i find out what it is im going to be kicking myself!!!

 

I have now swapped back over to the unix hosting.  this is my "deal"

 

Web server

  • Apache/2.2.3 (CentOS)
  • MySQL client version: 5.1.31
  • PHP extension: mysqli

MySQL

  • Server: blah blah blah
  • Server version: 5.0.77
  • Protocol version: 10
  • User: [email protected]
  • MySQL charset: UTF-8 Unicode (utf8)
I have gone through the config.php can't find anything wrong in that.
i took the .htaccess apart bit by bit, still getting the following........

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Apache/2.2.3 (CentOS) Server at www.sunrisetrainingnvq.com Port 80


i know it's got to be something so simple, like a speech mark or an apostrophe somewhere !!!! lol
anonymous profile picture
Deleted user
Posts: 214

22 September 2010, 4:43 AM

Hi Sally,

If you can get access to them, your Apache Error logs would be really handy - they should tell you why it's being denied. I still think that it'll be the .htaccess file. You could try removing it entirely?

Andrew

anonymous profile picture
Deleted user
Posts: 5

22 September 2010, 5:00 AM

Hi

Im not sure how much help I can be as I have never used Windows as the host for Mahara. I did encounter a 500 error recently when I upgraded our Mahara server to the new version.

My problem was rooted in having to change our previous database from latin1 to utf-8 I managed this eventually got 1.3 installed it gave me my front page installed okay then suddenly error 500 and would not allow me to get my front page, however I could get to the admin side of things using

http:// myserver/mahara/admin

Have you tried to see if you can access this page as I only seemed to get the 500 on my main mahara page, after some digging around I found the culprit was that in my previous version I had installed the Learning plug-in but hadnt put the files/folder accross into the new install, this caused my 500 error.

I wasnt clear from your query whether you were installing a fresh mahara on the unix box or installing using a mysqlbackup from your windows install.

So if you can get the admin pages to come up there is a mismatch in your mahara files area compared to what the database says the structure is.

anonymous profile picture
Deleted user
Posts: 7

22 September 2010, 11:30 AM

You guys are amazing !!!!!!!

i deleted the .htaccess file, and hey, presto !!!!

the only problem i have now, is the log in - like i had on the windows server.  I have checked that my data folder is 777, and still having to sign in on every page i go to as an admin and user.  

I have seen this problem in a string somewhere in the support topics but can't find it now !!!

anonymous profile picture
Deleted user
Posts: 7

22 September 2010, 3:27 PM

oh another quicky, how do i stop the .htaccess from regenerating itself ? lol.

8 results