Forums | Mahara Community

Support /
cannot start mahara


anonymous profile picture
Deleted user
Posts: 9

13 September 2010, 5:59 AM

hi guys, i m totally new to mahara & this form.

I have been assigned a job to install mahara on centos 5.4,

i did completed all the steps to install mahara like, mysql,php,apache etc.

now when i start maraha in centos 5.4, http://localhost/mahara..

i get error php version is lower then 5.2....

i did search for an upgrade of php but i didn't found ne thing for i386..

please experts...m i missing something or did i configured something wrong...please let me know..i got stuk now..

thanks in advance...regards/Qureshi MR

François Marier's profile picture
Posts: 411

13 September 2010, 5:45 PM

Mahara 1.3 requires PHP 5.2 so unless you can upgrade the version of PHP running on your server, I would recommend installing Mahara 1.2.

Cheers,

Francois

anonymous profile picture
Deleted user
Posts: 9

14 September 2010, 8:11 AM

thanks francois for your quick reply.

As i told in my previous post that i m very very new 2 mahara.

i did tried everything, but failed to uninstall 1.3 mahara & install 1.2.

i did it my way..but no sucess same...error need 5.2 or greater PHP.

please tel me how to uninstall 1.3 ?

thanks in advance.

anonymous profile picture
Deleted user
Posts: 214

14 September 2010, 11:23 AM

Hi Pyare,

I'd really recommend that you run 1.3 if at all possible - there has been a huge amount of work on it recently and it is the latest stable version of Mahara. Development on version 1.2 of mahara will probably begin to slow down now as the development focus moves to 1.3. My experience with CentOS is fairly limited but I believe that CentOS 5.4 is also not the latest stable version...

I'd also really recommend running postgresql over MySQL - transactions are a nice thing to have.

That said, uninstalling mahara 1.3 should be a case of dropping the database, and removing the files (htdocs folder and the contents of your maharadata directory).

Installing mahara 1.2 should be almost exactly the same as 1.3.

 

Hope that this helps,

Andrew

anonymous profile picture
Deleted user
Posts: 9

15 September 2010, 1:25 AM

hi Andrew thanks 4 ur suggestion i would also like to work on mahara 1.3

but i m facing problem...mahara it's not starting...its asking for php 5.2 or greater version it.....& i didn;t found it on net

for i386 system...centos 5.4

if u have ne idea about it...please send me link..so i can keep it.

thanks

anonymous profile picture
Deleted user
Posts: 214

15 September 2010, 3:23 AM

Hi again Pyare,

As I said before, I'm not familiar with CentOS in any way, shape, or form. I use Debian because it's a stable distribution which a plethora of up-to-date packages available from trusted sources which are well tested. I'd really recommend it for a production environment.

That said, a quick google reveals that the CentOS testing repository has PHP version 5.2 onwards. You can find the repository at http://dev.centos.org/centos/5/testing/. Googling for 'cent os php 5 yum' reveals this particularly useful wiki on the subject http://wiki.centos.org/HowTos/PHP_5.1_To_5.2

DISCLAIMER:

Please note, I offer no warranty for this source; I have no idea how security works (or doesn't work) with CentOS; I have no idea how you validate the sources of RPMs (if that's even possible); and I'd really recommend a stable community supported distribution like Debian or Ubuntu over an 'Enterprise' system such as CentOS or RedHat - but that's my personal preference.

6 results